add configure option --enable-appdata and put all appdata in appdata/
[claws.git] / src / plugins / clamd / Makefile.am
index f2fccb2a26d204999528a6b023ce2ca894708866..b59c84e26def96acb532af3831d54390d2e64b0e 100644 (file)
@@ -1,7 +1,13 @@
+# Makefile.am for "src/plugins/clamd" directory
+# This file is part of Claws Mail package.
+# See COPYING file for license details.
+
 SUBDIRS = libclamd
 plugindir = $(pkglibdir)/plugins
 
+if BUILD_CLAMD_PLUGIN
 plugin_LTLIBRARIES = clamd.la
+endif
 
 clamd_la_SOURCES = \
        clamav_plugin.c \
@@ -16,15 +22,11 @@ clamd_la_LDFLAGS = \
 clamd_la_LIBADD = \
        -lclamd-plugin
 
-INCLUDES = \
+clamd_la_CPPFLAGS = \
        -I$(top_srcdir)/src/plugins/clamd/libclamd \
        -I$(top_srcdir)/src \
        -I$(top_srcdir)/src/common \
-       -I$(top_srcdir)/src/gtk
-
-AM_CPPFLAGS = \
-       -Wall \
-       $(CLAWS_MAIL_CFLAGS) \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk \
        $(GLIB_CFLAGS) \
-       $(GTK_CFLAGS) \
-       -DLOCALEDIR=\""$(localedir)"\"
+       $(GTK_CFLAGS)