metainfo: add clamd plugin
[claws.git] / src / plugins / clamd / Makefile.am
index 9ff0438c95617abecd5d045716ff0ec09311cc36..29a6b3639ae86cf596c31014d2502336c185e8b7 100644 (file)
@@ -1,3 +1,12 @@
+# Makefile.am for "src/plugins/clamd" directory
+# This file is part of Claws Mail package.
+# See COPYING file for license details.
+
+appdata_files = claws-mail-clamd.metainfo.xml
+appdatadir = $(datadir)/appdata
+appdata_DATA = $(appdata_files)
+EXTRA_DIST = $(appdata_files)
+
 SUBDIRS = libclamd
 plugindir = $(pkglibdir)/plugins
 
@@ -18,13 +27,11 @@ clamd_la_LDFLAGS = \
 clamd_la_LIBADD = \
        -lclamd-plugin
 
-INCLUDES = \
+clamd_la_CPPFLAGS = \
        -I$(top_srcdir)/src/plugins/clamd/libclamd \
        -I$(top_srcdir)/src \
        -I$(top_srcdir)/src/common \
        -I$(top_builddir)/src/common \
-       -I$(top_srcdir)/src/gtk
-
-AM_CPPFLAGS = \
+       -I$(top_srcdir)/src/gtk \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS)