Replace deprecated INCLUDES with AM_CPPFLAGS; where needed, still
[claws.git] / src / plugins / bsfilter / Makefile.am
index f919b0599be836abf176b2285df9ed2bec564f1d..d30e3643141cd6c29925f15c804b75c61c1e8301 100644 (file)
@@ -1,9 +1,15 @@
 EXTRA_DIST = claws.def plugin.def version.rc
 
+IFLAGS = \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk
+
 if OS_WIN32
 
 LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.lo : %.rc
@@ -57,13 +63,14 @@ bsfilter_la_DEPENDENCIES = $(plugin_deps)
 bsfilter_la_LIBADD = $(plugin_ldadd) $(cygwin_export_lib) \
        $(GTK_LIBS) $(PTHREAD_LIBS) 
 
-INCLUDES = \
+IFLAGS = \
        -I$(top_srcdir)/src \
        -I$(top_srcdir)/src/common \
        -I$(top_builddir)/src/common \
        -I$(top_srcdir)/src/gtk
 
-AM_CPPFLAGS = \
+bsfilter_la_CPPFLAGS = \
+       $(IFLAGS) \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS)