Same for bsfilter
[claws.git] / src / plugins / bsfilter / Makefile.am
index b6f17c1d6c3d0c58801e412c9d27260e59d694de..b5308115151baa45ef4a9233fcd8a6aa7476fc1c 100644 (file)
@@ -1,9 +1,25 @@
-EXTRA_DIST = claws.def plugin.def version.rc
+# Makefile.am for "src/plugins/bsfilter" directory
+# This file is part of Claws Mail package.
+# See COPYING file for license details.
+
+appdata_files = claws-mail-bsfilter.metainfo.xml
+appdatadir = $(datadir)/appdata
+appdata_DATA = $(appdata_files)
+
+@INTLTOOL_XML_RULE@
+
+EXTRA_DIST = claws.def plugin.def version.rc $(appdata_DATA)
+
+IFLAGS = \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk
 
 if OS_WIN32
 
 LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.lo : %.rc
@@ -50,20 +66,15 @@ endif
 bsfilter_la_LDFLAGS = \
        $(plugin_res_ldflag) $(no_undefined) $(export_symbols) \
        -avoid-version -module \
-       $(GTK_LIBS)
+       $(GTK_LIBS) $(PTHREAD_LIBS) 
 
 bsfilter_la_DEPENDENCIES = $(plugin_deps)
 
 bsfilter_la_LIBADD = $(plugin_ldadd) $(cygwin_export_lib) \
-       $(GTK_LIBS)
-
-INCLUDES = \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/common \
-       -I$(top_builddir)/src/common \
-       -I$(top_srcdir)/src/gtk
+       $(GTK_LIBS) $(PTHREAD_LIBS) 
 
-AM_CPPFLAGS = \
+bsfilter_la_CPPFLAGS = \
+       $(IFLAGS) \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS)