RSSyl: Allow use of .netrc by libcurl. Bug/enhancement #3309, by Vincent Pelletier
[claws.git] / src / plugins / bsfilter / Makefile.am
index fd1d8244851bec2e5c5ef377c42b2acf92989618..a39eb05617e04cdf18684d15c844cb5a5224bfe0 100644 (file)
@@ -1,9 +1,20 @@
+# Copyright 1999-2014 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
+# See COPYING file for license details.
+
 EXTRA_DIST = claws.def plugin.def version.rc
 
+IFLAGS = \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk
+
 if OS_WIN32
 
 LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.lo : %.rc
@@ -43,30 +54,24 @@ endif
 
 plugindir = $(pkglibdir)/plugins
 
+if BUILD_BSFILTER_PLUGIN
 plugin_LTLIBRARIES = bsfilter.la
+endif
 
 bsfilter_la_LDFLAGS = \
        $(plugin_res_ldflag) $(no_undefined) $(export_symbols) \
        -avoid-version -module \
-       $(GTK_LIBS)
+       $(GTK_LIBS) $(PTHREAD_LIBS) 
 
 bsfilter_la_DEPENDENCIES = $(plugin_deps)
 
 bsfilter_la_LIBADD = $(plugin_ldadd) $(cygwin_export_lib) \
-       $(GTK_LIBS)
-
-INCLUDES = \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/common \
-       -I$(top_builddir)/src/common \
-       -I$(top_srcdir)/src/gtk
+       $(GTK_LIBS) $(PTHREAD_LIBS) 
 
-AM_CPPFLAGS = \
-       -Wall \
-       $(CLAWS_MAIL_CFLAGS) \
+bsfilter_la_CPPFLAGS = \
+       $(IFLAGS) \
        $(GLIB_CFLAGS) \
-       $(GTK_CFLAGS) \
-       -DLOCALEDIR=\""$(localedir)"\" 
+       $(GTK_CFLAGS)
 
 bsfilter_la_SOURCES = \
        bsfilter.c bsfilter.h \