Fix double define
[claws.git] / src / plugins / bsfilter / Makefile.am
index b3390de666fa875716263d4f146f4b8385730f28..5feae174e2459c480bd51e5c6643103e5f40ee4f 100644 (file)
@@ -1,9 +1,15 @@
 EXTRA_DIST = claws.def plugin.def version.rc
 
+IFLAGS = \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk
+
 if OS_WIN32
 
 LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.lo : %.rc
@@ -50,25 +56,17 @@ endif
 bsfilter_la_LDFLAGS = \
        $(plugin_res_ldflag) $(no_undefined) $(export_symbols) \
        -avoid-version -module \
-       $(GTK_LIBS)
+       $(GTK_LIBS) $(PTHREAD_LIBS) 
 
 bsfilter_la_DEPENDENCIES = $(plugin_deps)
 
 bsfilter_la_LIBADD = $(plugin_ldadd) $(cygwin_export_lib) \
-       $(GTK_LIBS)
-
-INCLUDES = \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/common \
-       -I$(top_builddir)/src/common \
-       -I$(top_srcdir)/src/gtk
+       $(GTK_LIBS) $(PTHREAD_LIBS) 
 
-AM_CPPFLAGS = \
-       -Wall \
-       $(CLAWS_MAIL_CFLAGS) \
+bsfilter_la_CPPFLAGS = \
+       $(IFLAGS) \
        $(GLIB_CFLAGS) \
-       $(GTK_CFLAGS) \
-       -DLOCALEDIR=\""$(localedir)"\" 
+       $(GTK_CFLAGS)
 
 bsfilter_la_SOURCES = \
        bsfilter.c bsfilter.h \