RSSyl: Allow use of .netrc by libcurl. Bug/enhancement #3309, by Vincent Pelletier
[claws.git] / src / plugins / bogofilter / Makefile.am
index c16d4e340b69922395eb94cc758a2bc608a19586..fd41b2c9aeba0af9eb70961bae58ab500dbf28da 100644 (file)
@@ -1,6 +1,13 @@
+# Copyright 1999-2014 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
+# See COPYING file for license details.
+
 plugindir = $(pkglibdir)/plugins
 
+if BUILD_BOGOFILTER_PLUGIN
 plugin_LTLIBRARIES = bogofilter.la
+endif
 
 bogofilter_la_SOURCES = \
        bogofilter.c bogofilter.h \
@@ -15,16 +22,13 @@ else
 cygwin_export_lib =
 endif
 bogofilter_la_LIBADD = $(cygwin_export_lib) \
-       $(GTK_LIBS)     \
-       $(OPENSSL_LIBS)
+       $(GTK_LIBS)
 
-INCLUDES = \
+bogofilter_la_CPPFLAGS = \
        -I$(top_srcdir)/src \
        -I$(top_srcdir)/src/common \
-       -I$(top_srcdir)/src/gtk
-
-AM_CPPFLAGS = \
-       $(ASPELL_CFLAGS) \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk \
+       $(ENCHANT_CFLAGS) \
        $(GLIB_CFLAGS) \
-       $(GTK_CFLAGS) \
-       $(OPENSSL_CFLAGS)
+       $(GTK_CFLAGS)