Missing @INTLTOOL_XML_RULE@
[claws.git] / src / plugins / attachwarner / Makefile.am
index d40ebc47e09a49959f26e883da4722742a7e56b9..c7dcaa5e06352181912d66ca37fdc5a33371bcbd 100644 (file)
@@ -1,9 +1,25 @@
-EXTRA_DIST = claws.def plugin.def version.rc
+# Makefile.am for "src/plugins/attachwarner" directory
+# This file is part of Claws Mail package.
+# See COPYING file for license details.
+
+appdata_in_files = claws-mail-attachwarner.metainfo.xml.in
+appdatadir=$(datadir)/appdata
+appdata_DATA = $(appdata_in_files:.xml.in=.xml)
+
+@INTLTOOL_XML_RULE@
+
+EXTRA_DIST = claws.def plugin.def version.rc $(appdata_DATA)
+
+IFLAGS = \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk
 
 if OS_WIN32
 
 LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.lo : %.rc
@@ -57,13 +73,8 @@ attachwarner_la_DEPENDENCIES = $(plugin_deps)
 attachwarner_la_LIBADD = $(plugin_ldadd) $(cygwin_export_lib) \
        $(GTK_LIBS)
 
-INCLUDES = \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/common \
-       -I$(top_builddir)/src/common \
-       -I$(top_srcdir)/src/gtk
-
-AM_CPPFLAGS = \
+attachwarner_la_CPPFLAGS = \
+       $(IFLAGS) \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS)