metainfo: add att_remover plugin
[claws.git] / src / plugins / att_remover / Makefile.am
index cf7f5764185d23cf2da3cc55e2c2f7062af00240..39ab4f5477397b755d9c13b3ea2cf36eacb9f63d 100644 (file)
@@ -1,9 +1,22 @@
-EXTRA_DIST = claws.def plugin.def version.rc
+# Makefile.am for "src/plugins/att_remover" directory
+# This file is part of Claws Mail package.
+# See COPYING file for license details.
+
+appdata_files = claws-mail-att_remover.metainfo.xml
+appdatadir = $(datadir)/appdata
+appdata_DATA = $(appdata_files)
+EXTRA_DIST = claws.def plugin.def version.rc $(appdata_files)
+
+IFLAGS = \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk
 
 if OS_WIN32
 
 LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.lo : %.rc
@@ -51,18 +64,16 @@ att_remover_la_SOURCES = \
        att_remover.c
 
 att_remover_la_LDFLAGS = \
-       -avoid-version -module
+       $(plugin_res_ldflag) $(no_undefined) $(export_symbols) \
+       -avoid-version -module \
+       $(GTK_LIBS)
 
-att_remover_la_LIBADD = \
+att_remover_la_LIBADD = $(plugin_ldadd) $(cygwin_export_lib) \
        $(GTK_LIBS)
 
-AM_CPPFLAGS = \
-       $(CLAWS_MAIL_CFLAGS) \
+att_remover_la_DEPENDENCIES = $(plugin_deps)
+
+att_remover_la_CPPFLAGS = \
+       $(IFLAGS) \
        $(GLIB_CFLAGS) \
        $(GTK_CFLAGS)
-
-INCLUDES = \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/common \
-       -I$(top_builddir)/src/common \
-       -I$(top_srcdir)/src/gtk