Fix bug #3380. Initialize widget before callback handler for 'clicked'
[claws.git] / src / plugins / address_keeper / Makefile.am
index 655700f191e37487893e68553bc8de9936a480a3..56e7965abef29e46f8ca2b4671730233352e1e6a 100644 (file)
@@ -1,9 +1,20 @@
+# Copyright 1999-2014 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
+# See COPYING file for license details.
+
 EXTRA_DIST = claws.def plugin.def version.rc
 
 EXTRA_DIST = claws.def plugin.def version.rc
 
+IFLAGS = \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/common \
+       -I$(top_builddir)/src/common \
+       -I$(top_srcdir)/src/gtk
+
 if OS_WIN32
 
 LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
 if OS_WIN32
 
 LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.lo : %.rc
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.lo : %.rc
@@ -43,7 +54,9 @@ endif
 
 plugindir = $(pkglibdir)/plugins
 
 
 plugindir = $(pkglibdir)/plugins
 
+if BUILD_ADDRESS_KEEPER_PLUGIN
 plugin_LTLIBRARIES = address_keeper.la
 plugin_LTLIBRARIES = address_keeper.la
+endif
 
 address_keeper_la_LDFLAGS = \
        $(plugin_res_ldflag) $(no_undefined) $(export_symbols) \
 
 address_keeper_la_LDFLAGS = \
        $(plugin_res_ldflag) $(no_undefined) $(export_symbols) \
@@ -55,18 +68,10 @@ address_keeper_la_DEPENDENCIES = $(plugin_deps)
 address_keeper_la_LIBADD = $(plugin_ldadd) $(cygwin_export_lib) \
        $(GTK_LIBS)
 
 address_keeper_la_LIBADD = $(plugin_ldadd) $(cygwin_export_lib) \
        $(GTK_LIBS)
 
-INCLUDES = \
-       -I$(top_srcdir)/src \
-       -I$(top_srcdir)/src/common \
-       -I$(top_builddir)/src/common \
-       -I$(top_srcdir)/src/gtk
-
-AM_CPPFLAGS = \
-       -Wall \
-       $(CLAWS_MAIL_CFLAGS) \
+address_keeper_la_CPPFLAGS = \
+       $(IFLAGS) \
        $(GLIB_CFLAGS) \
        $(GLIB_CFLAGS) \
-       $(GTK_CFLAGS) \
-       -DLOCALEDIR=\""$(localedir)"\" 
+       $(GTK_CFLAGS)
 
 address_keeper_la_SOURCES = \
        address_keeper.c address_keeper.h \
 
 address_keeper_la_SOURCES = \
        address_keeper.c address_keeper.h \