fix CID 1596595: Resource leaks, and CID 1596594: (CHECKED_RETURN)
[claws.git] / src / plugins / address_keeper / Makefile.am
index f9f32098b0e58bc218a731e888a7b59ba7c3fca9..4f44e6bf108c6a4fc1b5412d2b2976b218329159 100644 (file)
@@ -1,62 +1,17 @@
-# Makefile.am for "src/plugins/address_keeper" directory
-# This file is part of Claws Mail package.
+# Copyright 1999-2022 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
 # See COPYING file for license details.
 
-appdata_in_files = claws-mail-address_keeper.metainfo.xml.in
-appdatadir=$(datadir)/appdata
-appdata_DATA = $(appdata_in_files:.xml.in=.xml)
-
-@INTLTOOL_XML_RULE@
-
-EXTRA_DIST = claws.def plugin.def version.rc $(appdata_DATA)
+include $(srcdir)/../win_plugin.mk
 
 IFLAGS = \
+       -I$(top_builddir)/src \
+       -I$(top_builddir)/src/common \
        -I$(top_srcdir)/src \
        -I$(top_srcdir)/src/common \
-       -I$(top_builddir)/src/common \
        -I$(top_srcdir)/src/gtk
 
-if OS_WIN32
-
-LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
-     sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
-
-%.lo : %.rc
-       $(LTRCCOMPILE) -i $< -o $@
-
-plugin_res = version.lo
-plugin_res_ldflag = -Wl,.libs/version.o
-
-export_symbols = -export-symbols $(srcdir)/plugin.def
-
-plugin_deps = libclaws.a $(plugin_res) plugin.def
-
-libclaws.a: claws.def
-       $(DLLTOOL) --output-lib $@ --def $<
-
-plugin_ldadd = -L. -lclaws
-
-else
-plugin_res =
-plugin_res_ldflag =
-export_symbols =
-plugin_deps =
-plugin_ldadd =
-endif
-
-if PLATFORM_WIN32
-no_undefined = -no-undefined
-else
-no_undefined =
-endif
-
-if CYGWIN
-cygwin_export_lib = -L$(top_builddir)/src -lclaws-mail
-else
-cygwin_export_lib = 
-endif
-
 plugindir = $(pkglibdir)/plugins
 
 if BUILD_ADDRESS_KEEPER_PLUGIN
@@ -64,21 +19,24 @@ plugin_LTLIBRARIES = address_keeper.la
 endif
 
 address_keeper_la_LDFLAGS = \
-       $(plugin_res_ldflag) $(no_undefined) $(export_symbols) \
-       -avoid-version -module \
-       $(GTK_LIBS)
+       $(plugin_ldflags) \
+       -avoid-version -module -z noexecstack
 
-address_keeper_la_DEPENDENCIES = $(plugin_deps)
+EXTRA_address_keeper_la_DEPENDENCIES = $(plugin_extra_deps)
 
-address_keeper_la_LIBADD = $(plugin_ldadd) $(cygwin_export_lib) \
+address_keeper_la_LIBADD = $(plugin_libadd) \
        $(GTK_LIBS)
 
 address_keeper_la_CPPFLAGS = \
        $(IFLAGS) \
        $(GLIB_CFLAGS) \
-       $(GTK_CFLAGS)
+       $(GTK_CFLAGS) \
+       $(ENCHANT_CFLAGS)
 
 address_keeper_la_SOURCES = \
-       address_keeper.c address_keeper.h \
-       address_keeper_prefs.c address_keeper_prefs.h
+       address_keeper.c \
+       address_keeper.h \
+       address_keeper_prefs.c \
+       address_keeper_prefs.h
 
+.PHONY: test