2005-12-02 [paul] 1.9.100cvs55
[claws.git] / src / plugins / Makefile.am
index b65d0b2012112e06889dd4e93e2ca1da7139a35b..c9727a8992e6848aafd86cc0d2b6fd82daf15d3c 100644 (file)
@@ -1,2 +1,43 @@
-SUBDIRS = demo spamassassin
+if BUILD_DEMO_PLUGIN
+demo_dir = demo
+endif
 
+if BUILD_SPAMASSASSIN_PLUGIN
+spamassasssin_dir = spamassassin
+endif
+
+if BUILD_MATHML_VIEWER_PLUGIN
+mathml_viewer_dir = mathml_viewer
+endif
+
+if BUILD_DILLO_VIEWER_PLUGIN
+dillo_viewer_dir = dillo_viewer
+endif
+
+if BUILD_TRAYICON_PLUGIN
+trayicon_dir = trayicon
+endif
+
+if BUILD_CLAMAV_PLUGIN
+clamav_dir = clamav
+endif
+
+if BUILD_PGPCORE_PLUGIN
+pgpcore_dir = pgpcore
+if BUILD_PGPMIME_PLUGIN
+pgpmime_dir = pgpmime
+endif
+if BUILD_PGPINLINE_PLUGIN
+pgpinline_dir = pgpinline
+endif
+endif
+
+SUBDIRS = $(demo_dir) \
+       $(spamassasssin_dir) \
+       $(mathml_viewer_dir) \
+       $(dillo_viewer_dir) \
+       $(trayicon_dir) \
+       $(clamav_dir) \
+       $(pgpcore_dir) \
+       $(pgpmime_dir) \
+       $(pgpinline_dir)