Add a plugin method to allow updating stored passwords on master password change.
[claws.git] / src / plugins / Makefile.am
index 433c99277c8f6719990dc59c321543a9838098e5..6acc1fb36dddf1248f9815550fad9c77e43d9d5d 100644 (file)
@@ -1,35 +1,35 @@
-if BUILD_DEMO_PLUGIN
-demo_dir = demo
-endif
+# Copyright 1999-2014 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
+# See COPYING file for license details.
 
-if BUILD_SPAMASSASSIN_PLUGIN
-spamassasssin_dir = spamassassin
-endif
-
-if BUILD_MATHML_VIEWER_PLUGIN
-mathml_viewer_dir = mathml_viewer
-endif
-
-if BUILD_DILLO_VIEWER_PLUGIN
-dillo_viewer_dir = dillo_viewer
-endif
-
-if BUILD_TRAYICON_PLUGIN
-trayicon_dir = trayicon
-endif
-
-if BUILD_CLAMAV_PLUGIN
-clamav_dir = clamav
-endif
-
-if BUILD_PGPMIME_PLUGIN
-pgpmime_dir = pgpmime
-endif
-
-SUBDIRS = $(demo_dir) \
-       $(spamassasssin_dir) \
-       $(mathml_viewer_dir) \
-       $(dillo_viewer_dir) \
-       $(trayicon_dir) \
-       $(clamav_dir) \
-       $(pgpmime_dir)
+SUBDIRS = \
+       acpi_notifier \
+       address_keeper \
+       archive \
+       att_remover \
+       attachwarner \
+       bogofilter \
+       bsfilter \
+       clamd \
+       demo \
+       fancy \
+       fetchinfo \
+       gdata \
+       libravatar \
+       mailmbox \
+       managesieve \
+       newmail \
+       notification \
+       pdf_viewer \
+       perl \
+       python \
+       pgpcore \
+       pgpmime \
+       pgpinline \
+       rssyl \
+       smime \
+       spamassassin \
+       spam_report \
+       tnef_parse \
+       vcalendar