2005-12-05 [paul] 1.9.100cvs63
[claws.git] / src / plugins / Makefile.am
index 0830d867045f8e3c58562f674fae05587a8260c1..1fb853f4bb13fa28b8632c67f0eae2e3580e40bb 100644 (file)
@@ -6,15 +6,33 @@ if BUILD_SPAMASSASSIN_PLUGIN
 spamassasssin_dir = spamassassin
 endif
 
-if BUILD_MATHML_VIEWER_PLUGIN
-mathml_viewer_dir = mathml_viewer
-endif
-
 if BUILD_DILLO_VIEWER_PLUGIN
 dillo_viewer_dir = dillo_viewer
 endif
 
+if BUILD_TRAYICON_PLUGIN
+trayicon_dir = trayicon
+endif
+
+if BUILD_CLAMAV_PLUGIN
+clamav_dir = clamav
+endif
 
-SUBDIRS = $(demo_dir) $(spamassasssin_dir) $(mathml_viewer_dir) \
-         $(dillo_viewer_dir) 
+if BUILD_PGPCORE_PLUGIN
+pgpcore_dir = pgpcore
+if BUILD_PGPMIME_PLUGIN
+pgpmime_dir = pgpmime
+endif
+if BUILD_PGPINLINE_PLUGIN
+pgpinline_dir = pgpinline
+endif
+endif
 
+SUBDIRS = $(demo_dir) \
+       $(spamassasssin_dir) \
+       $(dillo_viewer_dir) \
+       $(trayicon_dir) \
+       $(clamav_dir) \
+       $(pgpcore_dir) \
+       $(pgpmime_dir) \
+       $(pgpinline_dir)