2009-05-21 [paul] 3.7.1cvs59
[claws.git] / src / gtk / Makefile.am
index 60b679ef348d71b642f48f2c9c8d4933683e73a6..fc9d3a548a16f8c6025a28503a3770724f992d18 100644 (file)
@@ -15,7 +15,9 @@ libclawsgtk_la_SOURCES = \
        filesel.c \
        foldersort.c \
        gtkaspell.c \
-       gtksctree.c \
+       gtkcmctree.c \
+       gtkcmclist.c \
+       gtkcmoptionmenu.c \
        gtkshruler.c \
        gtksctree.c \
        gtksourceprintjob.c \
@@ -30,6 +32,7 @@ libclawsgtk_la_SOURCES = \
        prefswindow.c \
        progressdialog.c \
        quicksearch.c \
+       spell_entry.c \
        sslcertwindow.c \
        claws-marshal.c
 
@@ -44,9 +47,11 @@ clawsgtkinclude_HEADERS = \
        filesel.h \
        foldersort.h \
        gtkaspell.h \
+       gtkcmctree.h \
+       gtkcmclist.h \
+       gtkcmoptionmenu.h \
        gtksctree.h \
        gtkshruler.h \
-       gtksctree.h \
        gtksourceprintjob.h \
        gtkutils.h \
        gtkvscrollbutton.h \
@@ -58,27 +63,28 @@ clawsgtkinclude_HEADERS = \
        menu.h \
        pluginwindow.h \
        prefswindow.h \
-       gtkvscrollbutton.h \
        progressdialog.h \
        quicksearch.h \
+       spell_entry.h \
        sslcertwindow.h \
        claws-marshal.h
 
 AM_CPPFLAGS = \
        -I$(srcdir)/../common \
+       -I../common \
        -I$(srcdir)/.. \
+       -I$(builddir)/.. \
        $(GTK_CFLAGS) \
-       $(OPENSSL_CFLAGS) \
-       $(ASPELL_CFLAGS) \
        $(GNOMEPRINT_CFLAGS) \
        $(MAEMO_CFLAGS) \
+       $(ENCHANT_CFLAGS) \
        -DPLUGINDIR=\"$(PLUGINDIR)\" \
        -DDOCDIR=\"$(DOCDIR)\" 
 
 libclawsgtk_la_LIBADD = \
        ../common/libclawscommon.la \
        $(GTK_LIBS) \
-       $(ASPELL_LIBS) \
+       $(ENCHANT_LIBS) \
        $(GNOMEPRINT_LIBS) \
        $(MAEMO_LIBS)