inital gtk2 patch
[claws.git] / src / gtk / Makefile.am
index 950a6e5b6c655aac804d9aeef91a4a778c7c6fee..eafa6f059d6f62ad4bf4dfcdc90e6e6a42e1f5e7 100644 (file)
@@ -1,14 +1,61 @@
 noinst_LTLIBRARIES = libsylpheedgtk.la
 
+EXTRA_DIST = \
+       sylpheed-marshal.list
+
 libsylpheedgtk_la_SOURCES = \
-       gtksctree.c gtksctree.h \
-       gtkstext.c gtkstext.h \
-       sslcertwindow.c sslcertwindow.h
+       about.c \
+       colorlabel.c \
+       colorsel.c \
+       description_window.c \
+       filesel.c \
+       gtkaspell.c \
+       gtkutils.c \
+       gtkshruler.c \
+       gtksctree.c \
+       manage_window.c \
+       menu.c \
+       pluginwindow.c \
+       prefswindow.c \
+       sslcertwindow.c \
+       sylpheed-marshal.c \
+       gtkvscrollbutton.c
+
+sylpheedgtkincludedir = $(pkgincludedir)/gtk
+sylpheedgtkinclude_HEADERS = \
+       about.h \
+       colorlabel.h \
+       colorsel.h \
+       description_window.h \
+       filesel.h \
+       gtkaspell.h \
+       gtkutils.h \
+       gtkshruler.h \
+       gtksctree.h \
+       manage_window.h \
+       menu.h \
+       pluginwindow.h \
+       prefswindow.h \
+       sslcertwindow.h \
+       sylpheed-marshal.h \
+       gtkvscrollbutton.h
 
-INCLUDES = \
+AM_CPPFLAGS = \
        -I../common \
-       $(GTK_CFLAGS)
+       -I.. \
+       $(GTK_CFLAGS) \
+       $(OPENSSL_CFLAGS) \
+       $(ASPELL_CFLAGS)
 
 libsylpheedgtk_la_LIBADD = \
        ../common/libsylpheedcommon.la \
-       $(GTK_LIBS)
+       $(GTK_LIBS) \
+       $(ASPELL_LIBS)
+
+BUILT_SOURCES=sylpheed-marshal.c sylpheed-marshal.h
+
+sylpheed-marshal.h: sylpheed-marshal.list
+       $(GLIB_GENMARSHAL) $< --header --prefix=sylpheed_marshal > $@
+
+sylpheed-marshal.c: sylpheed-marshal.list
+       $(GLIB_GENMARSHAL) $< --body --prefix=sylpheed_marshal > $@