0.9.5claws23
[claws.git] / src / gtk / Makefile.am
index 950a6e5b6c655aac804d9aeef91a4a778c7c6fee..d076dc0ebc9c841dc5f538a1644d0d506f59d01e 100644 (file)
@@ -1,14 +1,52 @@
 noinst_LTLIBRARIES = libsylpheedgtk.la
 
 libsylpheedgtk_la_SOURCES = \
-       gtksctree.c gtksctree.h \
-       gtkstext.c gtkstext.h \
-       sslcertwindow.c sslcertwindow.h
+       about.c \
+       colorlabel.c \
+       colorsel.c \
+       description_window.c \
+       filesel.c \
+       gtkaspell.c \
+       gtksctree.c \
+       gtkshruler.c \
+       gtkstext.c \
+       gtkutils.c \
+       gtkvscrollbutton.c \
+       logwindow.c \
+       manage_window.c \
+       menu.c \
+       pluginwindow.c \
+       prefswindow.c \
+       sslcertwindow.c
 
-INCLUDES = \
+sylpheedgtkincludedir = $(pkgincludedir)/gtk
+sylpheedgtkinclude_HEADERS = \
+       about.h \
+       colorlabel.h \
+       colorsel.h \
+       description_window.h \
+       filesel.h \
+       gtkaspell.h \
+       gtksctree.h \
+       gtkshruler.h \
+       gtkstext.h \
+       gtkutils.h \
+       gtkvscrollbutton.h \
+       logwindow.h \
+       manage_window.h \
+       menu.h \
+       pluginwindow.h \
+       prefswindow.h \
+       sslcertwindow.h
+
+AM_CPPFLAGS = \
        -I../common \
-       $(GTK_CFLAGS)
+       -I.. \
+       $(GTK_CFLAGS) \
+       $(OPENSSL_CFLAGS) \
+       $(ASPELL_CFLAGS)
 
 libsylpheedgtk_la_LIBADD = \
        ../common/libsylpheedcommon.la \
-       $(GTK_LIBS)
+       $(GTK_LIBS) \
+       $(ASPELL_LIBS)