2011-10-07 [colin] 3.7.10cvs21
[claws.git] / src / gtk / Makefile.am
index f2f10a10201a52db0890b65510795817a608df93..be15aab4ab6ed3de0ae4bfb869454ca908a0092a 100644 (file)
@@ -15,12 +15,6 @@ libclawsgtk_la_SOURCES = \
        filesel.c \
        foldersort.c \
        gtkaspell.c \
-       gtkcmctree.c \
-       gtkcmclist.c \
-       gtkcmoptionmenu.c \
-       gtkshruler.c \
-       gtksctree.c \
-       gtksourceprintjob.c \
        gtkutils.c \
        gtkvscrollbutton.c \
        icon_legend.c \
@@ -32,6 +26,7 @@ libclawsgtk_la_SOURCES = \
        prefswindow.c \
        progressdialog.c \
        quicksearch.c \
+       spell_entry.c \
        sslcertwindow.c \
        claws-marshal.c
 
@@ -46,12 +41,6 @@ clawsgtkinclude_HEADERS = \
        filesel.h \
        foldersort.h \
        gtkaspell.h \
-       gtkcmctree.h \
-       gtkcmclist.h \
-       gtkcmoptionmenu.h \
-       gtksctree.h \
-       gtkshruler.h \
-       gtksourceprintjob.h \
        gtkutils.h \
        gtkvscrollbutton.h \
        headers.h \
@@ -62,20 +51,34 @@ clawsgtkinclude_HEADERS = \
        menu.h \
        pluginwindow.h \
        prefswindow.h \
-       gtkvscrollbutton.h \
        progressdialog.h \
        quicksearch.h \
+       spell_entry.h \
        sslcertwindow.h \
        claws-marshal.h
 
+if GTK2
+libclawsgtk_la_SOURCES += \
+       gtkcmctree.c \
+       gtkcmclist.c \
+       gtkcmoptionmenu.c \
+       gtksctree.c \
+       gtkshruler.c
+
+clawsgtkinclude_HEADERS += \
+       gtkcmctree.h \
+       gtkcmclist.h \
+       gtkcmoptionmenu.h \
+       gtksctree.h \
+       gtkshruler.h
+endif
+
 AM_CPPFLAGS = \
        -I$(srcdir)/../common \
        -I../common \
        -I$(srcdir)/.. \
        -I$(builddir)/.. \
        $(GTK_CFLAGS) \
-       $(OPENSSL_CFLAGS) \
-       $(GNOMEPRINT_CFLAGS) \
        $(MAEMO_CFLAGS) \
        $(ENCHANT_CFLAGS) \
        -DPLUGINDIR=\"$(PLUGINDIR)\" \
@@ -85,7 +88,6 @@ libclawsgtk_la_LIBADD = \
        ../common/libclawscommon.la \
        $(GTK_LIBS) \
        $(ENCHANT_LIBS) \
-       $(GNOMEPRINT_LIBS) \
        $(MAEMO_LIBS)
 
 BUILT_SOURCES=claws-marshal.c claws-marshal.h