Use native file and folder selection dialogs on Windows.
[claws.git] / src / gtk / Makefile.am
index fc9d3a548a16f8c6025a28503a3770724f992d18..a2bcae0d29a81a2174400195338d5e7017cb9a3f 100644 (file)
@@ -1,3 +1,8 @@
+# Copyright 1999-2014 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
+# See COPYING file for license details.
+
 PLUGINDIR = $(pkglibdir)/plugins/
 DOCDIR = $(docdir)
 
@@ -6,21 +11,32 @@ noinst_LTLIBRARIES = libclawsgtk.la
 EXTRA_DIST = \
        claws-marshal.list
 
+if GTK2
+gtk2_sources = \
+       gtkcmoptionmenu.c
+endif
+
+if OS_WIN32
+arch_sources = w32_filesel.c
+else
+arch_sources = filesel.c
+endif
+
 libclawsgtk_la_SOURCES = \
        about.c \
        colorlabel.c \
        colorsel.c \
        combobox.c \
        description_window.c \
-       filesel.c \
+       $(arch_sources) \
        foldersort.c \
        gtkaspell.c \
        gtkcmctree.c \
        gtkcmclist.c \
-       gtkcmoptionmenu.c \
-       gtkshruler.c \
        gtksctree.c \
-       gtksourceprintjob.c \
+       gtkunit.c \
+       $(gtk2_sources) \
+       gtkshruler.c \
        gtkutils.c \
        gtkvscrollbutton.c \
        icon_legend.c \
@@ -47,13 +63,8 @@ clawsgtkinclude_HEADERS = \
        filesel.h \
        foldersort.h \
        gtkaspell.h \
-       gtkcmctree.h \
-       gtkcmclist.h \
-       gtkcmoptionmenu.h \
-       gtksctree.h \
-       gtkshruler.h \
-       gtksourceprintjob.h \
        gtkutils.h \
+       gtkunit.h \
        gtkvscrollbutton.h \
        headers.h \
        icon_legend.h \
@@ -67,7 +78,13 @@ clawsgtkinclude_HEADERS = \
        quicksearch.h \
        spell_entry.h \
        sslcertwindow.h \
-       claws-marshal.h
+       claws-marshal.h \
+       gtkcmctree.h \
+       gtkcmclist.h \
+       gtkcmoptionmenu.h \
+       gtksctree.h \
+       gtkshruler.h \
+       gdkkeysyms-new.h
 
 AM_CPPFLAGS = \
        -I$(srcdir)/../common \
@@ -75,8 +92,6 @@ AM_CPPFLAGS = \
        -I$(srcdir)/.. \
        -I$(builddir)/.. \
        $(GTK_CFLAGS) \
-       $(GNOMEPRINT_CFLAGS) \
-       $(MAEMO_CFLAGS) \
        $(ENCHANT_CFLAGS) \
        -DPLUGINDIR=\"$(PLUGINDIR)\" \
        -DDOCDIR=\"$(DOCDIR)\" 
@@ -84,9 +99,7 @@ AM_CPPFLAGS = \
 libclawsgtk_la_LIBADD = \
        ../common/libclawscommon.la \
        $(GTK_LIBS) \
-       $(ENCHANT_LIBS) \
-       $(GNOMEPRINT_LIBS) \
-       $(MAEMO_LIBS)
+       $(ENCHANT_LIBS)
 
 BUILT_SOURCES=claws-marshal.c claws-marshal.h