Use native file and folder selection dialogs on Windows.
[claws.git] / src / gtk / Makefile.am
index c88d8bb6aeea917dc266d69ee4616c4c587ff31e..a2bcae0d29a81a2174400195338d5e7017cb9a3f 100644 (file)
@@ -1,3 +1,8 @@
+# Copyright 1999-2014 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
+# See COPYING file for license details.
+
 PLUGINDIR = $(pkglibdir)/plugins/
 DOCDIR = $(docdir)
 
@@ -8,11 +13,13 @@ EXTRA_DIST = \
 
 if GTK2
 gtk2_sources = \
-       gtkcmctree.c \
-       gtkcmclist.c \
-       gtkcmoptionmenu.c \
-       gtksctree.c \
-       gtkshruler.c
+       gtkcmoptionmenu.c
+endif
+
+if OS_WIN32
+arch_sources = w32_filesel.c
+else
+arch_sources = filesel.c
 endif
 
 libclawsgtk_la_SOURCES = \
@@ -21,10 +28,15 @@ libclawsgtk_la_SOURCES = \
        colorsel.c \
        combobox.c \
        description_window.c \
-       filesel.c \
+       $(arch_sources) \
        foldersort.c \
        gtkaspell.c \
+       gtkcmctree.c \
+       gtkcmclist.c \
+       gtksctree.c \
+       gtkunit.c \
        $(gtk2_sources) \
+       gtkshruler.c \
        gtkutils.c \
        gtkvscrollbutton.c \
        icon_legend.c \
@@ -52,6 +64,7 @@ clawsgtkinclude_HEADERS = \
        foldersort.h \
        gtkaspell.h \
        gtkutils.h \
+       gtkunit.h \
        gtkvscrollbutton.h \
        headers.h \
        icon_legend.h \
@@ -79,7 +92,6 @@ AM_CPPFLAGS = \
        -I$(srcdir)/.. \
        -I$(builddir)/.. \
        $(GTK_CFLAGS) \
-       $(MAEMO_CFLAGS) \
        $(ENCHANT_CFLAGS) \
        -DPLUGINDIR=\"$(PLUGINDIR)\" \
        -DDOCDIR=\"$(DOCDIR)\" 
@@ -87,8 +99,7 @@ AM_CPPFLAGS = \
 libclawsgtk_la_LIBADD = \
        ../common/libclawscommon.la \
        $(GTK_LIBS) \
-       $(ENCHANT_LIBS) \
-       $(MAEMO_LIBS)
+       $(ENCHANT_LIBS)
 
 BUILT_SOURCES=claws-marshal.c claws-marshal.h