remove --enable-gtk3 configure flag
[claws.git] / src / gtk / Makefile.am
index c88d8bb6aeea917dc266d69ee4616c4c587ff31e..0cbd8aea995002744d6f1b5d7316240451b21291 100644 (file)
@@ -1,3 +1,8 @@
+# Copyright 1999-2014 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
+# See COPYING file for license details.
+
 PLUGINDIR = $(pkglibdir)/plugins/
 DOCDIR = $(docdir)
 
@@ -6,13 +11,10 @@ noinst_LTLIBRARIES = libclawsgtk.la
 EXTRA_DIST = \
        claws-marshal.list
 
-if GTK2
-gtk2_sources = \
-       gtkcmctree.c \
-       gtkcmclist.c \
-       gtkcmoptionmenu.c \
-       gtksctree.c \
-       gtkshruler.c
+if OS_WIN32
+arch_sources = w32_filesel.c
+else
+arch_sources = filesel.c
 endif
 
 libclawsgtk_la_SOURCES = \
@@ -21,10 +23,15 @@ libclawsgtk_la_SOURCES = \
        colorsel.c \
        combobox.c \
        description_window.c \
-       filesel.c \
+       $(arch_sources) \
        foldersort.c \
        gtkaspell.c \
-       $(gtk2_sources) \
+       gtkcmctree.c \
+       gtkcmclist.c \
+       gtkcmoptionmenu.c \
+       gtksctree.c \
+       gtkunit.c \
+       gtkshruler.c \
        gtkutils.c \
        gtkvscrollbutton.c \
        icon_legend.c \
@@ -52,6 +59,7 @@ clawsgtkinclude_HEADERS = \
        foldersort.h \
        gtkaspell.h \
        gtkutils.h \
+       gtkunit.h \
        gtkvscrollbutton.h \
        headers.h \
        icon_legend.h \
@@ -79,7 +87,6 @@ AM_CPPFLAGS = \
        -I$(srcdir)/.. \
        -I$(builddir)/.. \
        $(GTK_CFLAGS) \
-       $(MAEMO_CFLAGS) \
        $(ENCHANT_CFLAGS) \
        -DPLUGINDIR=\"$(PLUGINDIR)\" \
        -DDOCDIR=\"$(DOCDIR)\" 
@@ -87,8 +94,7 @@ AM_CPPFLAGS = \
 libclawsgtk_la_LIBADD = \
        ../common/libclawscommon.la \
        $(GTK_LIBS) \
-       $(ENCHANT_LIBS) \
-       $(MAEMO_LIBS)
+       $(ENCHANT_LIBS)
 
 BUILT_SOURCES=claws-marshal.c claws-marshal.h 
 
@@ -97,3 +103,5 @@ claws-marshal.h: claws-marshal.list
 
 claws-marshal.c: claws-marshal.list
        $(GLIB_GENMARSHAL) $< --body --prefix=claws_marshal > $@
+
+.PHONY: test