remove --enable-gtk3 configure flag
[claws.git] / src / gtk / Makefile.am
index 4f904001f2b8460792954840008deb9093a9c5cc..0cbd8aea995002744d6f1b5d7316240451b21291 100644 (file)
@@ -1,3 +1,8 @@
+# Copyright 1999-2014 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
+# See COPYING file for license details.
+
 PLUGINDIR = $(pkglibdir)/plugins/
 DOCDIR = $(docdir)
 
@@ -6,21 +11,27 @@ noinst_LTLIBRARIES = libclawsgtk.la
 EXTRA_DIST = \
        claws-marshal.list
 
+if OS_WIN32
+arch_sources = w32_filesel.c
+else
+arch_sources = filesel.c
+endif
+
 libclawsgtk_la_SOURCES = \
        about.c \
        colorlabel.c \
        colorsel.c \
        combobox.c \
        description_window.c \
-       filesel.c \
+       $(arch_sources) \
        foldersort.c \
        gtkaspell.c \
        gtkcmctree.c \
        gtkcmclist.c \
        gtkcmoptionmenu.c \
-       gtkshruler.c \
        gtksctree.c \
-       gtksourceprintjob.c \
+       gtkunit.c \
+       gtkshruler.c \
        gtkutils.c \
        gtkvscrollbutton.c \
        icon_legend.c \
@@ -47,13 +58,8 @@ clawsgtkinclude_HEADERS = \
        filesel.h \
        foldersort.h \
        gtkaspell.h \
-       gtkcmctree.h \
-       gtkcmclist.h \
-       gtkcmoptionmenu.h \
-       gtksctree.h \
-       gtkshruler.h \
-       gtksourceprintjob.h \
        gtkutils.h \
+       gtkunit.h \
        gtkvscrollbutton.h \
        headers.h \
        icon_legend.h \
@@ -63,12 +69,17 @@ clawsgtkinclude_HEADERS = \
        menu.h \
        pluginwindow.h \
        prefswindow.h \
-       gtkvscrollbutton.h \
        progressdialog.h \
        quicksearch.h \
        spell_entry.h \
        sslcertwindow.h \
-       claws-marshal.h
+       claws-marshal.h \
+       gtkcmctree.h \
+       gtkcmclist.h \
+       gtkcmoptionmenu.h \
+       gtksctree.h \
+       gtkshruler.h \
+       gdkkeysyms-new.h
 
 AM_CPPFLAGS = \
        -I$(srcdir)/../common \
@@ -76,8 +87,6 @@ AM_CPPFLAGS = \
        -I$(srcdir)/.. \
        -I$(builddir)/.. \
        $(GTK_CFLAGS) \
-       $(GNOMEPRINT_CFLAGS) \
-       $(MAEMO_CFLAGS) \
        $(ENCHANT_CFLAGS) \
        -DPLUGINDIR=\"$(PLUGINDIR)\" \
        -DDOCDIR=\"$(DOCDIR)\" 
@@ -85,9 +94,7 @@ AM_CPPFLAGS = \
 libclawsgtk_la_LIBADD = \
        ../common/libclawscommon.la \
        $(GTK_LIBS) \
-       $(ENCHANT_LIBS) \
-       $(GNOMEPRINT_LIBS) \
-       $(MAEMO_LIBS)
+       $(ENCHANT_LIBS)
 
 BUILT_SOURCES=claws-marshal.c claws-marshal.h 
 
@@ -96,3 +103,5 @@ claws-marshal.h: claws-marshal.list
 
 claws-marshal.c: claws-marshal.list
        $(GLIB_GENMARSHAL) $< --body --prefix=claws_marshal > $@
+
+.PHONY: test