Factorize SSL things in etpan
[claws.git] / src / etpan / Makefile.am
index c587cfb9c9d89a6d8f3774970ce40683285caf88..eb343b24a4a77d9a2ca8cb118e2cfe707fca9a0b 100644 (file)
@@ -5,7 +5,8 @@ noinst_LTLIBRARIES = libclawsetpan.la
 libclawsetpan_la_SOURCES = \
        etpan-thread-manager.c \
        imap-thread.c \
-       nntp-thread.c
+       nntp-thread.c \
+       etpan-ssl.c
 
 clawsetpanincludedir = $(pkgincludedir)/etpan
 clawsetpaninclude_HEADERS = \
@@ -13,7 +14,8 @@ clawsetpaninclude_HEADERS = \
        etpan-thread-manager.h \
        etpan-errors.h \
        imap-thread.h \
-       nntp-thread.h
+       nntp-thread.h \
+       etpan-ssl.h
 
 INCLUDES = \
        -I$(top_srcdir)/src \
@@ -22,9 +24,11 @@ INCLUDES = \
 
 AM_CPPFLAGS = \
        $(GTK_CFLAGS) \
-       $(LIBETPAN_CFLAGS) 
+       $(LIBETPAN_CFLAGS) \
+       $(ENCHANT_CFLAGS)
 
 libclawsetpan_la_LIBADD = \
        ../common/libclawscommon.la \
        $(GTK_LIBS) \
-       $(LIBETPAN_LIBS)
+       $(LIBETPAN_LIBS) \
+       $(ENCHANT_LIBS)