Use GLib's implementation of Base64 instead of our own.
[claws.git] / src / common / Makefile.am
index 9d0d4e16081d7f6343851e41f6bfbfcbec8709f2..796fae30aba5cf4d609e3f316d168acc08584c65 100644 (file)
@@ -1,12 +1,29 @@
-noinst_LTLIBRARIES = libsylpheedcommon.la
+# Copyright 1999-2014 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
+# See COPYING file for license details.
 
-libsylpheedcommon_la_SOURCES = \
-       base64.c \
+PLUGINDIR = $(pkglibdir)/plugins/
+DESKTOPFILEPATH=$(datadir)/applications/claws-mail.desktop
+
+noinst_LTLIBRARIES = libclawscommon.la
+
+if OS_WIN32
+arch_sources = fnmatch.c \
+               w32_dirent.c w32_reg.c w32_signal.c w32_stat.c \
+               w32_stdio.c w32_stdlib.c w32_string.c w32_time.c \
+               w32_unistd.c w32_wait.c w32_account.c
+arch_headers = fnmatch.h w32lib.h
+else
+arch_files = 
+arch_header = 
+endif
+
+libclawscommon_la_SOURCES = $(arch_sources) \
        hooks.c \
        log.c \
        md5.c \
        mgutils.c \
-       nntp.c \
        passcrypt.c \
        plugin.c \
        prefs.c \
@@ -19,23 +36,21 @@ libsylpheedcommon_la_SOURCES = \
        ssl_certificate.c \
        string_match.c \
        stringtable.c \
-       sylpheed.c \
+       claws.c \
+       tags.c \
        template.c \
        utils.c \
        uuencode.c \
        xml.c \
        xmlprops.c
 
-sylpheedcommonincludedir = $(pkgincludedir)/common
-sylpheedcommoninclude_HEADERS = \
-       base64.h \
+clawscommonincludedir = $(pkgincludedir)/common
+clawscommoninclude_HEADERS = $(arch_headers) \
        defs.h \
        hooks.h \
-       intl.h \
        log.h \
        md5.h \
        mgutils.h \
-       nntp.h \
        passcrypt.h \
        plugin.h \
        prefs.h \
@@ -48,26 +63,31 @@ sylpheedcommoninclude_HEADERS = \
        ssl.h \
        string_match.h \
        stringtable.h \
-       sylpheed.h \
+       claws.h \
+       tags.h \
        template.h \
+       timing.h \
        utils.h \
        uuencode.h \
        version.h \
        xml.h \
        xmlprops.h
 
-INCLUDES = \
-       -I$(top_srcdir)/intl
-
 AM_CPPFLAGS = \
+       -I$(top_srcdir)/intl \
        $(GLIB_CFLAGS) \
-       $(OPENSSL_CFLAGS) \
-       -DLOCALEDIR=\""$(localedir)"\"
+       $(VALGRIND_CFLAGS) \
+       -DLOCALEDIR=\""$(localedir)"\" \
+       -DPLUGINDIR=\"$(PLUGINDIR)\" \
+       -DDATAROOTDIR=\""$(datarootdir)"\" \
+       -DDESKTOPFILEPATH=\"$(DESKTOPFILEPATH)\" \
+       -DGTK_DISABLE_DEPRECATED
 
-libsylpheedcommon_la_LIBADD = \
+libclawscommon_la_LIBADD = \
        $(GLIB_LIBS) \
-       $(OPENSSL_LIBS) \
-       $(CRYPT_LIBS)
+       $(CRYPT_LIBS) \
+       $(PTHREAD_LIBS)
 
 EXTRA_DIST = \
-       version.h.in
+       version.h.in fnmatch_loop.c
+