Use GLib's implementation of Base64 instead of our own.
[claws.git] / src / common / Makefile.am
index 97f8d9964288c30bee56700d6c02c304f65d9c2a..796fae30aba5cf4d609e3f316d168acc08584c65 100644 (file)
@@ -1,3 +1,8 @@
+# Copyright 1999-2014 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
+# See COPYING file for license details.
+
 PLUGINDIR = $(pkglibdir)/plugins/
 DESKTOPFILEPATH=$(datadir)/applications/claws-mail.desktop
 
@@ -15,7 +20,6 @@ arch_header =
 endif
 
 libclawscommon_la_SOURCES = $(arch_sources) \
-       base64.c \
        hooks.c \
        log.c \
        md5.c \
@@ -42,7 +46,6 @@ libclawscommon_la_SOURCES = $(arch_sources) \
 
 clawscommonincludedir = $(pkgincludedir)/common
 clawscommoninclude_HEADERS = $(arch_headers) \
-       base64.h \
        defs.h \
        hooks.h \
        log.h \
@@ -70,12 +73,9 @@ clawscommoninclude_HEADERS = $(arch_headers) \
        xml.h \
        xmlprops.h
 
-INCLUDES = \
-       -I$(top_srcdir)/intl
-
 AM_CPPFLAGS = \
+       -I$(top_srcdir)/intl \
        $(GLIB_CFLAGS) \
-       $(MAEMO_CFLAGS) \
        $(VALGRIND_CFLAGS) \
        -DLOCALEDIR=\""$(localedir)"\" \
        -DPLUGINDIR=\"$(PLUGINDIR)\" \
@@ -86,8 +86,7 @@ AM_CPPFLAGS = \
 libclawscommon_la_LIBADD = \
        $(GLIB_LIBS) \
        $(CRYPT_LIBS) \
-       $(PTHREAD_LIBS) \
-       $(MAEMO_LIBS)
+       $(PTHREAD_LIBS)
 
 EXTRA_DIST = \
        version.h.in fnmatch_loop.c