0.8.6claws90
[claws.git] / src / common / Makefile.am
index b99e82de86bff7f00159591902efe0c8076d33ff..6a9d3250c8f13e866b10706aab605391c645e4d7 100644 (file)
@@ -6,14 +6,23 @@ libsylpheedcommon_la_SOURCES = \
        log.c log.h \
        md5.c md5.h \
        nntp.c nntp.h \
+       session.c session.h \
+       smtp.c smtp.h \
        socket.c socket.h \
+       ssl_certificate.c ssl_certificate.h \
        ssl.c ssl.h \
+       sylpheed.c sylpheed.h \
        template.c template.h \
        utils.c utils.h \
        uuencode.c uuencode.h
 
 INCLUDES = \
-       $(GLIB_CFLAGS)
+       $(GLIB_CFLAGS) \
+       $(OPENSSL_CFLAGS)
+
+CPPFLAGS = \
+       -DLOCALEDIR=\""$(localedir)"\"
 
 libsylpheedcommon_la_LIBADD = \
-       $(GLIB_LIBS)
+       $(GLIB_LIBS) \
+       $(OPENSSL_LIBS)