Remove use of fnmatch(), in favour of GPatternSpec.
[claws.git] / src / common / Makefile.am
index 97f8d9964288c30bee56700d6c02c304f65d9c2a..65b3ab0600af9a0db8bfbb2bafb51ddb1f296c35 100644 (file)
@@ -1,21 +1,24 @@
+# Copyright 1999-2014 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
+# See COPYING file for license details.
+
 PLUGINDIR = $(pkglibdir)/plugins/
 DESKTOPFILEPATH=$(datadir)/applications/claws-mail.desktop
 
 noinst_LTLIBRARIES = libclawscommon.la
 
 if OS_WIN32
-arch_sources = fnmatch.c \
-               w32_dirent.c w32_reg.c w32_signal.c w32_stat.c \
+arch_sources = w32_reg.c w32_signal.c w32_stat.c \
                w32_stdio.c w32_stdlib.c w32_string.c w32_time.c \
                w32_unistd.c w32_wait.c w32_account.c
-arch_headers = fnmatch.h w32lib.h
+arch_headers = w32lib.h
 else
 arch_files = 
 arch_header = 
 endif
 
 libclawscommon_la_SOURCES = $(arch_sources) \
-       base64.c \
        hooks.c \
        log.c \
        md5.c \
@@ -42,7 +45,6 @@ libclawscommon_la_SOURCES = $(arch_sources) \
 
 clawscommonincludedir = $(pkgincludedir)/common
 clawscommoninclude_HEADERS = $(arch_headers) \
-       base64.h \
        defs.h \
        hooks.h \
        log.h \
@@ -64,18 +66,16 @@ clawscommoninclude_HEADERS = $(arch_headers) \
        tags.h \
        template.h \
        timing.h \
+       tlds.h \
        utils.h \
        uuencode.h \
        version.h \
        xml.h \
        xmlprops.h
 
-INCLUDES = \
-       -I$(top_srcdir)/intl
-
 AM_CPPFLAGS = \
+       -I$(top_srcdir)/intl \
        $(GLIB_CFLAGS) \
-       $(MAEMO_CFLAGS) \
        $(VALGRIND_CFLAGS) \
        -DLOCALEDIR=\""$(localedir)"\" \
        -DPLUGINDIR=\"$(PLUGINDIR)\" \
@@ -86,9 +86,8 @@ AM_CPPFLAGS = \
 libclawscommon_la_LIBADD = \
        $(GLIB_LIBS) \
        $(CRYPT_LIBS) \
-       $(PTHREAD_LIBS) \
-       $(MAEMO_LIBS)
+       $(PTHREAD_LIBS)
 
 EXTRA_DIST = \
-       version.h.in fnmatch_loop.c
+       version.h.in