Remove use of fnmatch(), in favour of GPatternSpec.
[claws.git] / src / common / Makefile.am
index 637001a95c3162ad4b28f0213fc8b54cdf1d5c1d..65b3ab0600af9a0db8bfbb2bafb51ddb1f296c35 100644 (file)
@@ -1,24 +1,28 @@
+# Copyright 1999-2014 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
+# See COPYING file for license details.
+
 PLUGINDIR = $(pkglibdir)/plugins/
+DESKTOPFILEPATH=$(datadir)/applications/claws-mail.desktop
+
 noinst_LTLIBRARIES = libclawscommon.la
 
 if OS_WIN32
-arch_sources = fnmatch.c \
-               w32_dirent.c w32_reg.c w32_signal.c w32_stat.c \
+arch_sources = w32_reg.c w32_signal.c w32_stat.c \
                w32_stdio.c w32_stdlib.c w32_string.c w32_time.c \
-               w32_unistd.c w32_wait.c
-arch_headers = fnmatch.h w32lib.h
+               w32_unistd.c w32_wait.c w32_account.c
+arch_headers = w32lib.h
 else
 arch_files = 
 arch_header = 
 endif
 
 libclawscommon_la_SOURCES = $(arch_sources) \
-       base64.c \
        hooks.c \
        log.c \
        md5.c \
        mgutils.c \
-       nntp.c \
        passcrypt.c \
        plugin.c \
        prefs.c \
@@ -41,13 +45,11 @@ libclawscommon_la_SOURCES = $(arch_sources) \
 
 clawscommonincludedir = $(pkgincludedir)/common
 clawscommoninclude_HEADERS = $(arch_headers) \
-       base64.h \
        defs.h \
        hooks.h \
        log.h \
        md5.h \
        mgutils.h \
-       nntp.h \
        passcrypt.h \
        plugin.h \
        prefs.h \
@@ -64,30 +66,28 @@ clawscommoninclude_HEADERS = $(arch_headers) \
        tags.h \
        template.h \
        timing.h \
+       tlds.h \
        utils.h \
        uuencode.h \
-       valgrind.h \
        version.h \
        xml.h \
        xmlprops.h
 
-INCLUDES = \
-       -I$(top_srcdir)/intl
-
 AM_CPPFLAGS = \
+       -I$(top_srcdir)/intl \
        $(GLIB_CFLAGS) \
-       $(OPENSSL_CFLAGS) \
-       $(MAEMO_CFLAGS) \
+       $(VALGRIND_CFLAGS) \
        -DLOCALEDIR=\""$(localedir)"\" \
-       -DPLUGINDIR=\"$(PLUGINDIR)\" 
+       -DPLUGINDIR=\"$(PLUGINDIR)\" \
+       -DDATAROOTDIR=\""$(datarootdir)"\" \
+       -DDESKTOPFILEPATH=\"$(DESKTOPFILEPATH)\" \
+       -DGTK_DISABLE_DEPRECATED
 
 libclawscommon_la_LIBADD = \
        $(GLIB_LIBS) \
-       $(OPENSSL_LIBS) \
        $(CRYPT_LIBS) \
-       $(PTHREAD_LIBS) \
-       $(MAEMO_LIBS)
+       $(PTHREAD_LIBS)
 
 EXTRA_DIST = \
-       version.h.in fnmatch_loop.c
+       version.h.in