Added unit test framework, and some initial unit tests.
[claws.git] / src / common / Makefile.am
index 56b6cdb088d9519b007b6574686c74af9d23621b..5c4f249573f42fa8a924a1c5ec414800fcc252c9 100644 (file)
@@ -3,6 +3,11 @@
 # terms of the General Public License version 3 (or later).
 # See COPYING file for license details.
 
+if BUILD_TESTS
+include $(top_srcdir)/tests.mk
+SUBDIRS = . tests
+endif
+
 PLUGINDIR = $(pkglibdir)/plugins/
 DESKTOPFILEPATH=$(datadir)/applications/claws-mail.desktop
 
@@ -98,4 +103,3 @@ libclawscommon_la_LIBADD = \
 
 EXTRA_DIST = \
        version.h.in
-