Added PBKDF2 implementation, copied from OpenBSD.
[claws.git] / src / common / Makefile.am
index 796fae30aba5cf4d609e3f316d168acc08584c65..1dd8e9190e8a81d26d73cb0b8d81f753a5cc4d95 100644 (file)
@@ -9,11 +9,10 @@ DESKTOPFILEPATH=$(datadir)/applications/claws-mail.desktop
 noinst_LTLIBRARIES = libclawscommon.la
 
 if OS_WIN32
-arch_sources = fnmatch.c \
-               w32_dirent.c w32_reg.c w32_signal.c w32_stat.c \
+arch_sources = w32_reg.c w32_signal.c w32_stat.c \
                w32_stdio.c w32_stdlib.c w32_string.c w32_time.c \
                w32_unistd.c w32_wait.c w32_account.c
-arch_headers = fnmatch.h w32lib.h
+arch_headers = w32lib.h
 else
 arch_files = 
 arch_header = 
@@ -42,7 +41,8 @@ libclawscommon_la_SOURCES = $(arch_sources) \
        utils.c \
        uuencode.c \
        xml.c \
-       xmlprops.c
+       xmlprops.c \
+       pkcs5_pbkdf2.c
 
 clawscommonincludedir = $(pkgincludedir)/common
 clawscommoninclude_HEADERS = $(arch_headers) \
@@ -67,11 +67,13 @@ clawscommoninclude_HEADERS = $(arch_headers) \
        tags.h \
        template.h \
        timing.h \
+       tlds.h \
        utils.h \
        uuencode.h \
        version.h \
        xml.h \
-       xmlprops.h
+       xmlprops.h \
+       pkcs5_pbkdf2.h
 
 AM_CPPFLAGS = \
        -I$(top_srcdir)/intl \
@@ -89,5 +91,5 @@ libclawscommon_la_LIBADD = \
        $(PTHREAD_LIBS)
 
 EXTRA_DIST = \
-       version.h.in fnmatch_loop.c
+       version.h.in