Added PBKDF2 implementation, copied from OpenBSD.
[claws.git] / src / common / Makefile.am
index 515d469d1e6f9b6569567b67e6d0c7a2dfab28ee..1dd8e9190e8a81d26d73cb0b8d81f753a5cc4d95 100644 (file)
@@ -1,13 +1,28 @@
+# Copyright 1999-2014 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
+# See COPYING file for license details.
+
 PLUGINDIR = $(pkglibdir)/plugins/
-noinst_LTLIBRARIES = libsylpheedcommon.la
+DESKTOPFILEPATH=$(datadir)/applications/claws-mail.desktop
+
+noinst_LTLIBRARIES = libclawscommon.la
+
+if OS_WIN32
+arch_sources = w32_reg.c w32_signal.c w32_stat.c \
+               w32_stdio.c w32_stdlib.c w32_string.c w32_time.c \
+               w32_unistd.c w32_wait.c w32_account.c
+arch_headers = w32lib.h
+else
+arch_files = 
+arch_header = 
+endif
 
-libsylpheedcommon_la_SOURCES = \
-       base64.c \
+libclawscommon_la_SOURCES = $(arch_sources) \
        hooks.c \
        log.c \
        md5.c \
        mgutils.c \
-       nntp.c \
        passcrypt.c \
        plugin.c \
        prefs.c \
@@ -20,22 +35,22 @@ libsylpheedcommon_la_SOURCES = \
        ssl_certificate.c \
        string_match.c \
        stringtable.c \
-       sylpheed.c \
+       claws.c \
+       tags.c \
        template.c \
        utils.c \
        uuencode.c \
        xml.c \
-       xmlprops.c
+       xmlprops.c \
+       pkcs5_pbkdf2.c
 
-sylpheedcommonincludedir = $(pkgincludedir)/common
-sylpheedcommoninclude_HEADERS = \
-       base64.h \
+clawscommonincludedir = $(pkgincludedir)/common
+clawscommoninclude_HEADERS = $(arch_headers) \
        defs.h \
        hooks.h \
        log.h \
        md5.h \
        mgutils.h \
-       nntp.h \
        passcrypt.h \
        plugin.h \
        prefs.h \
@@ -48,29 +63,33 @@ sylpheedcommoninclude_HEADERS = \
        ssl.h \
        string_match.h \
        stringtable.h \
-       sylpheed.h \
+       claws.h \
+       tags.h \
        template.h \
        timing.h \
+       tlds.h \
        utils.h \
        uuencode.h \
        version.h \
        xml.h \
-       xmlprops.h
-
-INCLUDES = \
-       -I$(top_srcdir)/intl
+       xmlprops.h \
+       pkcs5_pbkdf2.h
 
 AM_CPPFLAGS = \
+       -I$(top_srcdir)/intl \
        $(GLIB_CFLAGS) \
-       $(OPENSSL_CFLAGS) \
+       $(VALGRIND_CFLAGS) \
        -DLOCALEDIR=\""$(localedir)"\" \
-       -DPLUGINDIR=\"$(PLUGINDIR)\" 
+       -DPLUGINDIR=\"$(PLUGINDIR)\" \
+       -DDATAROOTDIR=\""$(datarootdir)"\" \
+       -DDESKTOPFILEPATH=\"$(DESKTOPFILEPATH)\" \
+       -DGTK_DISABLE_DEPRECATED
 
-libsylpheedcommon_la_LIBADD = \
+libclawscommon_la_LIBADD = \
        $(GLIB_LIBS) \
-       $(OPENSSL_LIBS) \
        $(CRYPT_LIBS) \
        $(PTHREAD_LIBS)
 
 EXTRA_DIST = \
        version.h.in
+