Added PBKDF2 implementation, copied from OpenBSD.
[claws.git] / src / common / Makefile.am
index 508ba9d44072556cb960db0c6331937842039fcc..1dd8e9190e8a81d26d73cb0b8d81f753a5cc4d95 100644 (file)
@@ -1,19 +1,24 @@
+# Copyright 1999-2014 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
+# See COPYING file for license details.
+
 PLUGINDIR = $(pkglibdir)/plugins/
+DESKTOPFILEPATH=$(datadir)/applications/claws-mail.desktop
+
 noinst_LTLIBRARIES = libclawscommon.la
 
 if OS_WIN32
-arch_sources = fnmatch.c \
-               w32_dirent.c w32_reg.c w32_signal.c w32_stat.c \
+arch_sources = w32_reg.c w32_signal.c w32_stat.c \
                w32_stdio.c w32_stdlib.c w32_string.c w32_time.c \
                w32_unistd.c w32_wait.c w32_account.c
-arch_headers = fnmatch.h w32lib.h
+arch_headers = w32lib.h
 else
 arch_files = 
 arch_header = 
 endif
 
 libclawscommon_la_SOURCES = $(arch_sources) \
-       base64.c \
        hooks.c \
        log.c \
        md5.c \
@@ -36,11 +41,11 @@ libclawscommon_la_SOURCES = $(arch_sources) \
        utils.c \
        uuencode.c \
        xml.c \
-       xmlprops.c
+       xmlprops.c \
+       pkcs5_pbkdf2.c
 
 clawscommonincludedir = $(pkgincludedir)/common
 clawscommoninclude_HEADERS = $(arch_headers) \
-       base64.h \
        defs.h \
        hooks.h \
        log.h \
@@ -62,30 +67,29 @@ clawscommoninclude_HEADERS = $(arch_headers) \
        tags.h \
        template.h \
        timing.h \
+       tlds.h \
        utils.h \
        uuencode.h \
-       valgrind.h \
        version.h \
        xml.h \
-       xmlprops.h
-
-INCLUDES = \
-       -I$(top_srcdir)/intl
+       xmlprops.h \
+       pkcs5_pbkdf2.h
 
 AM_CPPFLAGS = \
+       -I$(top_srcdir)/intl \
        $(GLIB_CFLAGS) \
-       $(OPENSSL_CFLAGS) \
-       $(MAEMO_CFLAGS) \
+       $(VALGRIND_CFLAGS) \
        -DLOCALEDIR=\""$(localedir)"\" \
-       -DPLUGINDIR=\"$(PLUGINDIR)\" 
+       -DPLUGINDIR=\"$(PLUGINDIR)\" \
+       -DDATAROOTDIR=\""$(datarootdir)"\" \
+       -DDESKTOPFILEPATH=\"$(DESKTOPFILEPATH)\" \
+       -DGTK_DISABLE_DEPRECATED
 
 libclawscommon_la_LIBADD = \
        $(GLIB_LIBS) \
-       $(OPENSSL_LIBS) \
        $(CRYPT_LIBS) \
-       $(PTHREAD_LIBS) \
-       $(MAEMO_LIBS)
+       $(PTHREAD_LIBS)
 
 EXTRA_DIST = \
-       version.h.in fnmatch_loop.c
+       version.h.in