0.8.10claws70
[claws.git] / src / common / Makefile.am
index 76f9b6805e9c82709f0c54326b34ab478619e6de..0a494ed1a5c1407bcd005efb038a6a111721258a 100644 (file)
@@ -7,7 +7,10 @@ libsylpheedcommon_la_SOURCES = \
        intl.h \
        log.c log.h \
        md5.c md5.h \
+       mgutils.c mgutils.h \
        nntp.c nntp.h \
+       passcrypt.c passcrypt.h \
+       plugin.c plugin.h \
        prefs.c prefs.h \
        quoted-printable.c quoted-printable.h \
        session.c session.h \
@@ -15,19 +18,24 @@ libsylpheedcommon_la_SOURCES = \
        socket.c socket.h \
        ssl_certificate.c ssl_certificate.h \
        ssl.c ssl.h \
+       stringtable.c stringtable.h \
        sylpheed.c sylpheed.h \
        template.c template.h \
        utils.c utils.h \
+       uuencode.c uuencode.h \
        version.h \
-       uuencode.c uuencode.h
-
-INCLUDES = \
-       $(GLIB_CFLAGS) \
-       $(OPENSSL_CFLAGS)
+       xml.c xml.h \
+       xmlprops.c xmlprops.h
 
 CPPFLAGS = \
+       $(GLIB_CFLAGS) \
+       $(OPENSSL_CFLAGS) \
        -DLOCALEDIR=\""$(localedir)"\"
 
 libsylpheedcommon_la_LIBADD = \
        $(GLIB_LIBS) \
-       $(OPENSSL_LIBS)
+       $(OPENSSL_LIBS) \
+       -lcrypt
+
+EXTRA_DIST = \
+       version.h.in