2011-02-23 [colin] 3.7.8cvs59
[claws.git] / src / common / Makefile.am
index 515d469d1e6f9b6569567b67e6d0c7a2dfab28ee..082e026b3c836ab50e55e8a8894abdd06240ff7c 100644 (file)
@@ -1,13 +1,25 @@
 PLUGINDIR = $(pkglibdir)/plugins/
-noinst_LTLIBRARIES = libsylpheedcommon.la
+DESKTOPFILEPATH=$(datadir)/applications/claws-mail.desktop
 
-libsylpheedcommon_la_SOURCES = \
+noinst_LTLIBRARIES = libclawscommon.la
+
+if OS_WIN32
+arch_sources = fnmatch.c \
+               w32_dirent.c w32_reg.c w32_signal.c w32_stat.c \
+               w32_stdio.c w32_stdlib.c w32_string.c w32_time.c \
+               w32_unistd.c w32_wait.c w32_account.c
+arch_headers = fnmatch.h w32lib.h
+else
+arch_files = 
+arch_header = 
+endif
+
+libclawscommon_la_SOURCES = $(arch_sources) \
        base64.c \
        hooks.c \
        log.c \
        md5.c \
        mgutils.c \
-       nntp.c \
        passcrypt.c \
        plugin.c \
        prefs.c \
@@ -20,22 +32,22 @@ libsylpheedcommon_la_SOURCES = \
        ssl_certificate.c \
        string_match.c \
        stringtable.c \
-       sylpheed.c \
+       claws.c \
+       tags.c \
        template.c \
        utils.c \
        uuencode.c \
        xml.c \
        xmlprops.c
 
-sylpheedcommonincludedir = $(pkgincludedir)/common
-sylpheedcommoninclude_HEADERS = \
+clawscommonincludedir = $(pkgincludedir)/common
+clawscommoninclude_HEADERS = $(arch_headers) \
        base64.h \
        defs.h \
        hooks.h \
        log.h \
        md5.h \
        mgutils.h \
-       nntp.h \
        passcrypt.h \
        plugin.h \
        prefs.h \
@@ -48,7 +60,8 @@ sylpheedcommoninclude_HEADERS = \
        ssl.h \
        string_match.h \
        stringtable.h \
-       sylpheed.h \
+       claws.h \
+       tags.h \
        template.h \
        timing.h \
        utils.h \
@@ -62,15 +75,21 @@ INCLUDES = \
 
 AM_CPPFLAGS = \
        $(GLIB_CFLAGS) \
-       $(OPENSSL_CFLAGS) \
+       $(MAEMO_CFLAGS) \
+       $(VALGRIND_CFLAGS) \
        -DLOCALEDIR=\""$(localedir)"\" \
-       -DPLUGINDIR=\"$(PLUGINDIR)\" 
+       -DPLUGINDIR=\"$(PLUGINDIR)\" \
+       -DDATAROOTDIR=\""$(datarootdir)"\" \
+       -DDESKTOPFILEPATH=\"$(DESKTOPFILEPATH)\" \
+       -DGTK_DISABLE_DEPRECATED
 
-libsylpheedcommon_la_LIBADD = \
+libclawscommon_la_LIBADD = \
        $(GLIB_LIBS) \
-       $(OPENSSL_LIBS) \
        $(CRYPT_LIBS) \
-       $(PTHREAD_LIBS)
+       $(PTHREAD_LIBS) \
+       $(MAEMO_LIBS)
 
 EXTRA_DIST = \
-       version.h.in
+       valgrind.h \
+       version.h.in fnmatch_loop.c
+