Pass --export-* flags correctly to the linker, depending on platform.
[claws.git] / src / Makefile.am
index 12030c05e57ff12e4eda043a67ae451fdee4a51b..ef8267d384043a5242024dc4747da89ac52d339f 100644 (file)
@@ -1,3 +1,7 @@
+# Copyright 1999-2014 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
+# See COPYING file for license details.
 
 if CLAWS_LIBETPAN
 etpan_dir = etpan
@@ -15,8 +19,8 @@ install-exec-hook:
        @ln -s claws-mail $(DESTDIR)$(bindir)/sylpheed-claws
 
 if PLATFORM_WIN32
-LTRCCOMPILE = $(LIBTOOL) --mode=compile $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.o : %.rc
@@ -102,6 +106,7 @@ abook_headers = \
        expldifdlg.h \
        exporthtml.h \
        exportldif.h \
+       file_checker.h \
        importldif.h \
        importmutt.h \
        importpine.h \
@@ -126,8 +131,10 @@ claws_mail_SOURCES = \
        addrgather.c \
        addrharvest.c \
        addritem.c \
+       advsearch.c \
        alertpanel.c \
        autofaces.c \
+       avatars.c \
        codeconv.c \
        compose.c \
        crash.c \
@@ -136,6 +143,7 @@ claws_mail_SOURCES = \
        edittags.c \
        enriched.c \
        export.c \
+        file_checker.c \
        filtering.c \
        folder.c \
        folder_item_prefs.c \
@@ -238,8 +246,10 @@ claws_mailinclude_HEADERS = \
        addressitem.h \
        addrgather.h \
        addrharvest.h \
+       advsearch.h \
        alertpanel.h \
        autofaces.h \
+       avatars.h \
        codeconv.h \
        compose.h \
        crash.h \
@@ -267,6 +277,7 @@ claws_mailinclude_HEADERS = \
        mainwindow.h \
        manual.h \
        matcher.h \
+       matchertypes.h \
        matcher_parser.h \
        matcher_parser_lex.h \
        matcher_parser_parse.h \
@@ -369,6 +380,7 @@ EXTRA_DIST = \
        pixmaps/check_spelling.xpm \
        pixmaps/clipkey.xpm \
        pixmaps/claws-mail_icon.xpm \
+       pixmaps/claws-mail_compose_logo.xpm \
        pixmaps/claws-mail_logo.xpm \
        pixmaps/claws-mail_logo-small.xpm \
        pixmaps/claws-mail.xpm \
@@ -521,20 +533,20 @@ EXTRA_DIST = \
        $(abook_extra)
 
 
-INCLUDES = \
+IFLAGS = \
        -I$(srcdir)/common \
        -Icommon \
        -I$(srcdir)/gtk \
        -I$(srcdir)/etpan
 
 if PLATFORM_WIN32
-arch_ldflags := -export-all-symbols
+arch_ldflags := -Wl,--export-all-symbols
 else
-arch_ldflags :=
+arch_ldflags := -Wl,--export-dynamic
 endif
 
 claws_mail_LDFLAGS = \
-       $(arch_ldflags) -export-dynamic $(claws_mail_res_ldflag)
+       $(arch_ldflags) $(claws_mail_res_ldflag)
 
 claws_mail_DEPENDENCIES = $(claws_mail_deps) \
        $(etpan_library) \
@@ -546,7 +558,6 @@ claws_mail_LDADD = \
        $(ENCHANT_LIBS) \
        $(INTLLIBS) \
        $(GTK_LIBS) \
-       $(GPGME_LIBS) \
        $(LDAP_LIBS) \
        $(GNUTLS_LIBS) \
        $(COMPFACE_LIBS) \
@@ -556,8 +567,6 @@ claws_mail_LDADD = \
        $(LIBICONV) \
        $(STARTUP_NOTIFICATION_LIBS) \
        $(LIBETPAN_LIBS) \
-       $(MAEMO_LIBS) \
-       $(CONIC_LIBS) \
        $(DBUS_LIBS) \
        $(CONTACTS_LIBS)
 
@@ -568,17 +577,15 @@ AM_CPPFLAGS = \
        -DLOCALEDIR=\""$(localedir)"\" \
        -DPIXMAP_DIR=\""$(pixmapdir)"\" \
        -DMANUALDIR=\""$(manualdir)"\" \
-       -DFAQDIR=\""$(faqdir)"\" \
        -DTARGET_ALIAS=\""$(target_triplet)"\" \
        -DSYSCONFDIR=\""$(sysconfdir)"\" \
        -DDATAROOTDIR=\""$(datarootdir)"\" \
+       $(IFLAGS) \
        $(ENCHANT_CFLAGS) \
        $(GTK_CFLAGS) \
        $(GPGME_CFLAGS) \
        $(LIBETPAN_CPPFLAGS) \
        $(STARTUP_NOTIFICATION_CFLAGS) \
-       $(MAEMO_CFLAGS) \
-       $(CONIC_CFLAGS) \
        $(DBUS_CFLAGS) \
        $(NETWORKMANAGER_SUPPORT_CFLAGS) \
        $(VALGRIND_CFLAGS) \