Pass --export-* flags correctly to the linker, depending on platform.
[claws.git] / src / Makefile.am
index 0008fa061f1d6a7ec0f6c11be4a907df5ae87542..ef8267d384043a5242024dc4747da89ac52d339f 100644 (file)
@@ -1,8 +1,8 @@
-# Makefile.am for "src" directory
-# This file is part of Claws Mail package.
+# Copyright 1999-2014 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
 # See COPYING file for license details.
 
-
 if CLAWS_LIBETPAN
 etpan_dir = etpan
 etpan_library = etpan/libclawsetpan.la
@@ -540,13 +540,13 @@ IFLAGS = \
        -I$(srcdir)/etpan
 
 if PLATFORM_WIN32
-arch_ldflags := -export-all-symbols
+arch_ldflags := -Wl,--export-all-symbols
 else
-arch_ldflags :=
+arch_ldflags := -Wl,--export-dynamic
 endif
 
 claws_mail_LDFLAGS = \
-       $(arch_ldflags) -export-dynamic $(claws_mail_res_ldflag)
+       $(arch_ldflags) $(claws_mail_res_ldflag)
 
 claws_mail_DEPENDENCIES = $(claws_mail_deps) \
        $(etpan_library) \
@@ -558,7 +558,6 @@ claws_mail_LDADD = \
        $(ENCHANT_LIBS) \
        $(INTLLIBS) \
        $(GTK_LIBS) \
-       $(GPGME_LIBS) \
        $(LDAP_LIBS) \
        $(GNUTLS_LIBS) \
        $(COMPFACE_LIBS) \