2007-10-18 [wwp] 3.0.2cvs88
[claws.git] / src / Makefile.am
index 1d48e9b7dd623ff2bae2e468283eda53e6d5ff57..e580ef251477cb6e9dbf2d7c38066277ec883dc2 100644 (file)
@@ -30,6 +30,7 @@ claws_mail_SOURCES = \
        addritem.c \
        addrquery.c \
        addrselect.c \
+       addrduplicates.c \
        alertpanel.c \
        browseldap.c \
        codeconv.c \
@@ -38,11 +39,13 @@ claws_mail_SOURCES = \
        customheader.c \
        displayheader.c \
        editaddress.c \
+       editaddress_other_attributes_ldap.c \
        editbook.c \
        editgroup.c \
        editjpilot.c \
        editldap_basedn.c \
        editldap.c \
+       edittags.c \
        editvcard.c \
        enriched.c \
        exphtmldlg.c \
@@ -121,11 +124,13 @@ claws_mail_SOURCES = \
        prefs_spelling.c \
        prefs_summaries.c \
        prefs_summary_column.c \
+       prefs_summary_open.c \
        prefs_folder_column.c \
        prefs_template.c \
        prefs_themes.c \
        prefs_toolbar.c \
        prefs_wrapping.c \
+       printing.c \
        privacy.c \
        procheader.c \
        procmime.c \
@@ -172,6 +177,7 @@ claws_mailinclude_HEADERS = \
        addritem.h \
        addrquery.h \
        addrselect.h \
+       addrduplicates.h \
        alertpanel.h \
        browseldap.h \
        codeconv.h \
@@ -180,11 +186,13 @@ claws_mailinclude_HEADERS = \
        customheader.h \
        displayheader.h \
        editaddress.h \
+       editaddress_other_attributes_ldap.h \
        editbook.h \
        editgroup.h \
        editjpilot.h \
        editldap_basedn.h \
        editldap.h \
+       edittags.h \
        editvcard.h \
        enriched.h \
        exphtmldlg.h \
@@ -264,11 +272,13 @@ claws_mailinclude_HEADERS = \
        prefs_spelling.h \
        prefs_summaries.h \
        prefs_summary_column.h \
+       prefs_summary_open.h \
        prefs_folder_column.h \
        prefs_template.h \
        prefs_themes.h \
        prefs_toolbar.h \
        prefs_wrapping.h \
+       printing.h \
        privacy.h \
        procheader.h \
        procmime.h \
@@ -299,12 +309,12 @@ BUILT_SOURCES = \
        quote_fmt_parse.h
 
 EXTRA_DIST = \
-       pixmaps/active.xpm \
        pixmaps/addr_one.xpm \
        pixmaps/addr_two.xpm \
        pixmaps/address_book.xpm \
        pixmaps/address_search.xpm \
        pixmaps/address.xpm \
+       pixmaps/anonymous.xpm \
        pixmaps/book.xpm \
        pixmaps/category.xpm \
        pixmaps/checkbox_off.xpm \
@@ -332,15 +342,16 @@ EXTRA_DIST = \
        pixmaps/exec.xpm \
        pixmaps/forwarded.xpm \
        pixmaps/gpg_signed.xpm \
+       pixmaps/go_folders.xpm \
        pixmaps/group.xpm \
        pixmaps/ham_btn.xpm \
        pixmaps/ignorethread.xpm \
-       pixmaps/inactive.xpm \
        pixmaps/inbox_open_hrm.xpm \
        pixmaps/inbox_open.xpm \
        pixmaps/inbox_close_hrm.xpm \
        pixmaps/inbox_close.xpm \
        pixmaps/interface.xpm \
+       pixmaps/insert_file.xpm \
        pixmaps/jpilot.xpm \
        pixmaps/key.xpm \
        pixmaps/ldap.xpm \
@@ -390,6 +401,7 @@ EXTRA_DIST = \
        pixmaps/outbox_open_hrm_mark.xpm \
        pixmaps/paste.xpm \
        pixmaps/preferences.xpm \
+       pixmaps/printer.xpm \
        pixmaps/privacy_expired.xpm \
        pixmaps/privacy_failed.xpm \
        pixmaps/privacy_passed.xpm \
@@ -418,6 +430,7 @@ EXTRA_DIST = \
        pixmaps/spam_btn.xpm \
        pixmaps/claws-mail_icon.xpm \
        pixmaps/claws-mail_logo.xpm \
+       pixmaps/claws-mail_logo-small.xpm \
        pixmaps/claws-mail.xpm \
        pixmaps/trash_hrm.xpm \
        pixmaps/trash.xpm \
@@ -440,11 +453,13 @@ EXTRA_DIST = \
        pixmaps/trash_mark.xpm \
        pixmaps/moved.xpm \
        pixmaps/copied.xpm \
+       pixmaps/watchthread.xpm \
        pixmaps/empty.xpm
 
 
 INCLUDES = \
        -I$(srcdir)/common \
+       -Icommon \
        -I$(srcdir)/gtk \
        -I$(srcdir)/etpan
 
@@ -466,6 +481,7 @@ claws_mail_LDADD = \
        $(GPGME_LIBS) \
        $(LDAP_LIBS) \
        $(OPENSSL_LIBS) \
+       $(GNUTLS_LIBS) \
        $(COMPFACE_LIBS) \
        $(JPILOT_LIBS) \
        $(PTHREAD_LIBS) \
@@ -474,11 +490,15 @@ claws_mail_LDADD = \
        $(LIBICONV) \
        $(STARTUP_NOTIFICATION_LIBS) \
        $(LIBETPAN_LIBS) \
-       $(MAEMO_LIBS)
+       $(MAEMO_LIBS) \
+       $(CONIC_LIBS)
+
+pixmapdir=$(datadir)/icons/hicolor/48x48/apps
 
 AM_CPPFLAGS = \
        -DG_LOG_DOMAIN=\"Claws-Mail\" \
        -DLOCALEDIR=\""$(localedir)"\" \
+       -DPIXMAP_DIR=\""$(pixmapdir)"\" \
        -DMANUALDIR=\""$(manualdir)"\" \
        -DFAQDIR=\""$(faqdir)"\" \
        -DTARGET_ALIAS=\""$(target_triplet)"\" \
@@ -492,7 +512,7 @@ AM_CPPFLAGS = \
        $(LIBETPAN_CPPFLAGS) \
        $(STARTUP_NOTIFICATION_CFLAGS) \
        $(MAEMO_CFLAGS) \
-       -Wno-unused-function
+       $(CONIC_CFLAGS)
         
 #no-unused-function is there because of bison stuff
 #no-deprecated-declarations because of gpgme_data_rewind, which we have