Included import of LDIF files.
[claws.git] / src / Makefile.am
index c844be8a541267d4ee97944b35a1996d516bc0c4..db6d13495f122aa7b124e4f92ecee025a86abcc7 100644 (file)
@@ -34,6 +34,23 @@ sylpheed_SOURCES = \
        customheader.c customheader.h \
        addressbook.c addressbook.h \
        addr_compl.c addr_compl.h \
        customheader.c customheader.h \
        addressbook.c addressbook.h \
        addr_compl.c addr_compl.h \
+       addressitem.h \
+       addritem.c addritem.h \
+       addrcache.c addrcache.h \
+       addrbook.c addrbook.h \
+       addrindex.c addrindex.h \
+       mgutils.c mgutils.h \
+       vcard.c vcard.h \
+       jpilot.c jpilot.h \
+       syldap.c syldap.h \
+       editbook.c editbook.h \
+       editgroup.c editgroup.h \
+       editaddress.c editaddress.h \
+       editvcard.c editvcard.h \
+       editjpilot.c editjpilot.h \
+       editldap.c editldap.h \
+       editldap_basedn.c editldap_basedn.h \
+       addressadd.c addressadd.h \
        filesel.c filesel.h \
        foldersel.c foldersel.h \
        statusbar.c statusbar.h \
        filesel.c filesel.h \
        foldersel.c foldersel.h \
        statusbar.c statusbar.h \
@@ -74,6 +91,8 @@ sylpheed_SOURCES = \
        imap.c imap.h \
        xml.c xml.h \
        html.c html.h \
        imap.c imap.h \
        xml.c xml.h \
        html.c html.h \
+       ldif.c ldif.h \
+       importldif.c importldif.h \
        procmime.c procmime.h \
        rfc2015.c rfc2015.h \
        passphrase.c passphrase.h \
        procmime.c procmime.h \
        rfc2015.c rfc2015.h \
        passphrase.c passphrase.h \
@@ -93,23 +112,6 @@ sylpheed_SOURCES = \
        mbox_folder.c mbox_folder.h \
        quote_fmt_lex.l quote_fmt_lex.h \
        quote_fmt_parse.y quote_fmt.h \
        mbox_folder.c mbox_folder.h \
        quote_fmt_lex.l quote_fmt_lex.h \
        quote_fmt_parse.y quote_fmt.h \
-       addressitem.h \
-       addritem.c addritem.h \
-       addrcache.c addrcache.h \
-       addrbook.c addrbook.h \
-       addrindex.c addrindex.h \
-       mgutils.c mgutils.h \
-       vcard.c vcard.h \
-       jpilot.c jpilot.h \
-       syldap.c syldap.h \
-       editbook.c editbook.h \
-       editgroup.c editgroup.h \
-       editaddress.c editaddress.h \
-       editvcard.c editvcard.h \
-       editjpilot.c editjpilot.h \
-       editldap.c editldap.h \
-       editldap_basedn.c editldap_basedn.h \
-       addressadd.c addressadd.h \
        gtkspell.c gtkspell.h gtkxtext.h \
        template.c template.h \
        prefs_templates.c prefs_templates.h \
        gtkspell.c gtkspell.h gtkxtext.h \
        template.c template.h \
        prefs_templates.c prefs_templates.h \
@@ -161,14 +163,13 @@ EXTRA_DIST = \
        pixmaps/stock_paste.xpm \
        pixmaps/tb_address_book.xpm \
        pixmaps/sylpheed-logo.xpm \
        pixmaps/stock_paste.xpm \
        pixmaps/tb_address_book.xpm \
        pixmaps/sylpheed-logo.xpm \
-       pixmaps/interface.xpm \
-       pixmaps/book.xpm \
        pixmaps/address.xpm \
        pixmaps/address.xpm \
-       pixmaps/vcard.xpm \
-       pixmaps/jpilot.xpm \
+       pixmaps/book.xpm \
        pixmaps/category.xpm \
        pixmaps/category.xpm \
+       pixmaps/interface.xpm \
+       pixmaps/jpilot.xpm \
        pixmaps/ldap.xpm \
        pixmaps/ldap.xpm \
-       pixmaps/ignorethread.xpm
+       pixmaps/vcard.xpm
 
 INCLUDES = \
        -DG_LOG_DOMAIN=\"Sylpheed\" \
 
 INCLUDES = \
        -DG_LOG_DOMAIN=\"Sylpheed\" \
@@ -177,6 +178,7 @@ INCLUDES = \
        $(GTK_CFLAGS) \
        $(GDK_IMLIB_CFLAGS) \
        $(GDK_PIXBUF_CFLAGS) \
        $(GTK_CFLAGS) \
        $(GDK_IMLIB_CFLAGS) \
        $(GDK_PIXBUF_CFLAGS) \
+        $(PSPELL_CFLAGS)    \
        -I$(includedir)
 
 sylpheed_LDADD = \
        -I$(includedir)
 
 sylpheed_LDADD = \
@@ -185,7 +187,8 @@ sylpheed_LDADD = \
        $(GTK_LIBS) \
        $(GDK_IMLIB_LIBS) \
        $(GDK_PIXBUF_LIBS) \
        $(GTK_LIBS) \
        $(GDK_IMLIB_LIBS) \
        $(GDK_PIXBUF_LIBS) \
-       $(GPGME_LIBS)
+       $(GPGME_LIBS) \
+        $(PSPELL_LIBS)
 
 CPPFLAGS = \
        -DLOCALEDIR=\""$(localedir)"\" \
 
 CPPFLAGS = \
        -DLOCALEDIR=\""$(localedir)"\" \
@@ -200,4 +203,3 @@ BUILT_SOURCES = \
        quote_fmt_lex.c \
        quote_fmt_parse.c \
        quote_fmt_parse.h
        quote_fmt_lex.c \
        quote_fmt_parse.c \
        quote_fmt_parse.h
-