Included import of LDIF files.
[claws.git] / src / Makefile.am
index 546278b2d4209eeb3a746303303166ea7aa5a520..db6d13495f122aa7b124e4f92ecee025a86abcc7 100644 (file)
@@ -3,6 +3,7 @@ bin_PROGRAMS = sylpheed
 sylpheed_SOURCES = \
        intl.h \
        defs.h \
+       version.h \
        main.c main.h \
        mainwindow.c mainwindow.h \
        folderview.c folderview.h \
@@ -33,6 +34,23 @@ sylpheed_SOURCES = \
        customheader.c customheader.h \
        addressbook.c addressbook.h \
        addr_compl.c addr_compl.h \
+       addressitem.h \
+       addritem.c addritem.h \
+       addrcache.c addrcache.h \
+       addrbook.c addrbook.h \
+       addrindex.c addrindex.h \
+       mgutils.c mgutils.h \
+       vcard.c vcard.h \
+       jpilot.c jpilot.h \
+       syldap.c syldap.h \
+       editbook.c editbook.h \
+       editgroup.c editgroup.h \
+       editaddress.c editaddress.h \
+       editvcard.c editvcard.h \
+       editjpilot.c editjpilot.h \
+       editldap.c editldap.h \
+       editldap_basedn.c editldap_basedn.h \
+       addressadd.c addressadd.h \
        filesel.c filesel.h \
        foldersel.c foldersel.h \
        statusbar.c statusbar.h \
@@ -73,6 +91,8 @@ sylpheed_SOURCES = \
        imap.c imap.h \
        xml.c xml.h \
        html.c html.h \
+       ldif.c ldif.h \
+       importldif.c importldif.h \
        procmime.c procmime.h \
        rfc2015.c rfc2015.h \
        passphrase.c passphrase.h \
@@ -80,6 +100,7 @@ sylpheed_SOURCES = \
        sigstatus.c sigstatus.h \
        simple-gettext.c \
        manual.c manual.h \
+       stringtable.c stringtable.h \
        gtkstext.c gtkstext.h \
        scoring.c scoring.h \
        prefs_folder_item.c prefs_folder_item.h \
@@ -91,15 +112,6 @@ sylpheed_SOURCES = \
        mbox_folder.c mbox_folder.h \
        quote_fmt_lex.l quote_fmt_lex.h \
        quote_fmt_parse.y quote_fmt.h \
-       addressitem.h \
-       mgutils.c mgutils.h \
-       vcard.c vcard.h \
-       jpilot.c jpilot.h \
-       syldap.c syldap.h \
-       editvcard.c editvcard.h \
-       editjpilot.c editjpilot.h \
-       editldap.c editldap.h \
-       editldap_basedn.c editldap_basedn.h \
        gtkspell.c gtkspell.h gtkxtext.h \
        template.c template.h \
        prefs_templates.c prefs_templates.h \
@@ -108,6 +120,7 @@ sylpheed_SOURCES = \
 
 EXTRA_DIST = \
        quote_fmt_parse.h \
+       version.h.in \
        pixmaps/clip.xpm \
        pixmaps/deleted.xpm \
        pixmaps/dir-close.xpm \
@@ -150,11 +163,13 @@ EXTRA_DIST = \
        pixmaps/stock_paste.xpm \
        pixmaps/tb_address_book.xpm \
        pixmaps/sylpheed-logo.xpm \
-       pixmaps/vcard.xpm \
-       pixmaps/jpilot.xpm \
+       pixmaps/address.xpm \
+       pixmaps/book.xpm \
        pixmaps/category.xpm \
+       pixmaps/interface.xpm \
+       pixmaps/jpilot.xpm \
        pixmaps/ldap.xpm \
-       pixmaps/ignorethread.xpm
+       pixmaps/vcard.xpm
 
 INCLUDES = \
        -DG_LOG_DOMAIN=\"Sylpheed\" \
@@ -163,6 +178,7 @@ INCLUDES = \
        $(GTK_CFLAGS) \
        $(GDK_IMLIB_CFLAGS) \
        $(GDK_PIXBUF_CFLAGS) \
+        $(PSPELL_CFLAGS)    \
        -I$(includedir)
 
 sylpheed_LDADD = \
@@ -171,7 +187,8 @@ sylpheed_LDADD = \
        $(GTK_LIBS) \
        $(GDK_IMLIB_LIBS) \
        $(GDK_PIXBUF_LIBS) \
-       $(GPGME_LIBS)
+       $(GPGME_LIBS) \
+        $(PSPELL_LIBS)
 
 CPPFLAGS = \
        -DLOCALEDIR=\""$(localedir)"\" \
@@ -186,4 +203,3 @@ BUILT_SOURCES = \
        quote_fmt_lex.c \
        quote_fmt_parse.c \
        quote_fmt_parse.h
-