2005-04-01 [colin] 1.9.6cvs21
[claws.git] / src / Makefile.am
index debbcab0059514fb9263095128e2ea3e82e91977..dab83fd41d771f7ac108976825100e0d68a7d6e9 100644 (file)
@@ -46,6 +46,7 @@ sylpheed_SOURCES = \
        grouplistdialog.c \
        headerview.c \
        html.c \
+       image_viewer.c \
        imap.c \
        imap_gtk.c \
        import.c \
@@ -78,7 +79,7 @@ sylpheed_SOURCES = \
        news.c \
        news_gtk.c \
        noticeview.c \
-       passphrase.c \
+       partial_download.c \
        pine.c \
        pop.c \
        prefs_account.c \
@@ -92,6 +93,7 @@ sylpheed_SOURCES = \
        prefs_folder_item.c \
        prefs_fonts.c \
        prefs_gtk.c \
+       prefs_image_viewer.c \
        prefs_matcher.c \
        prefs_msg_colors.c \
        prefs_spelling.c \
@@ -109,8 +111,6 @@ sylpheed_SOURCES = \
        quote_fmt_parse.y \
        recv.c \
        remotefolder.c \
-       rfc2015.c \
-       select-keys.c \
        send_message.c \
        setup.c \
        simple-gettext.c \
@@ -124,7 +124,8 @@ sylpheed_SOURCES = \
        toolbar.c \
        undo.c \
        unmime.c \
-       vcard.c
+       vcard.c \
+       wizard.c
 
 sylpheedincludedir = $(pkgincludedir)
 sylpheedinclude_HEADERS = \
@@ -174,6 +175,7 @@ sylpheedinclude_HEADERS = \
        grouplistdialog.h \
        headerview.h \
        html.h \
+       image_viewer.h \
        imap.h \
        imap_gtk.h \
        import.h \
@@ -207,7 +209,7 @@ sylpheedinclude_HEADERS = \
        news.h \
        news_gtk.h \
        noticeview.h \
-       passphrase.h \
+       partial_download.h \
        pine.h \
        pop.h \
        prefs_account.h \
@@ -221,6 +223,7 @@ sylpheedinclude_HEADERS = \
        prefs_folder_item.h \
        prefs_fonts.h \
        prefs_gtk.h \
+       prefs_image_viewer.h \
        prefs_matcher.h \
        prefs_msg_colors.h \
        prefs_spelling.h \
@@ -238,8 +241,6 @@ sylpheedinclude_HEADERS = \
        quote_fmt_parse.h \
        recv.h \
        remotefolder.h \
-       rfc2015.h \
-       select-keys.h \
        send_message.h \
        setup.h \
        sourcewindow.h \
@@ -252,7 +253,8 @@ sylpheedinclude_HEADERS = \
        toolbar.h \
        undo.h \
        unmime.h \
-       vcard.h
+       vcard.h \
+       wizard.h
 
 BUILT_SOURCES = \
        matcher_parser_parse.h \
@@ -274,14 +276,14 @@ EXTRA_DIST = \
        pixmaps/continue.xpm \
        pixmaps/deleted.xpm \
        pixmaps/dir_close.xpm \
-       pixmaps/dir_open_hrm.xpm \
+       pixmaps/dir_noselect.xpm \
+        pixmaps/dir_open_hrm.xpm \
        pixmaps/dir_open.xpm \
        pixmaps/down_arrow.xpm \
        pixmaps/drafts_close.xpm \
        pixmaps/drafts_open.xpm \
        pixmaps/error.xpm \
        pixmaps/exec.xpm \
-       pixmaps/folder.xpm \
        pixmaps/forwarded.xpm \
        pixmaps/gpg_signed.xpm \
        pixmaps/group.xpm \
@@ -339,21 +341,21 @@ EXTRA_DIST = \
        pixmaps/privacy_emblem_warn.xpm \
        pixmaps/properties.xpm \
        pixmaps/quicksearch.xpm \
-       pixmaps/regular.xpm \
        pixmaps/replied.xpm \
        pixmaps/search.xpm \
+       pixmaps/sylpheed_icon.xpm \
        pixmaps/sylpheed_logo.xpm \
        pixmaps/sylpheed.xpm \
        pixmaps/trash_hrm.xpm \
        pixmaps/trash.xpm \
        pixmaps/unread.xpm \
+       pixmaps/read.xpm \
        pixmaps/up_arrow.xpm \
        pixmaps/vcard.xpm
 
 INCLUDES = \
        -Icommon \
-       -Igtk \
-       -I$(top_srcdir)/intl
+       -Igtk
 
 sylpheed_LDFLAGS = \
        -export-dynamic
@@ -368,7 +370,9 @@ sylpheed_LDADD = \
        $(OPENSSL_LIBS) \
        $(COMPFACE_LIBS) \
        $(JPILOT_LIBS) \
-       $(LIBICONV)
+       $(PTHREAD_LIBS) \
+       $(LIBICONV) \
+       $(STARTUP_NOTIFICATION_LIBS)
 
 AM_CPPFLAGS = \
        -DG_LOG_DOMAIN=\"Sylpheed\" \
@@ -380,6 +384,7 @@ AM_CPPFLAGS = \
        $(ASPELL_CFLAGS) \
        $(GTK_CFLAGS) \
        $(GPGME_CFLAGS) \
-       $(OPENSSL_CFLAGS)
+       $(OPENSSL_CFLAGS) \
+       $(STARTUP_NOTIFICATION_CFLAGS)
 
 AM_YFLAGS = -d