Do not link main binary to GPGME libraries
[claws.git] / src / Makefile.am
index 138cc204bdda1ec42f1533132d528caba0bae87a..d4b66276bcf831b3ff65ba7bd1e57bc16c3dba81 100644 (file)
@@ -1,3 +1,7 @@
+# Copyright 1999-2014 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
+# See COPYING file for license details.
 
 if CLAWS_LIBETPAN
 etpan_dir = etpan
@@ -15,8 +19,8 @@ install-exec-hook:
        @ln -s claws-mail $(DESTDIR)$(bindir)/sylpheed-claws
 
 if PLATFORM_WIN32
-LTRCCOMPILE = $(LIBTOOL) --mode=compile $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.o : %.rc
@@ -29,13 +33,57 @@ claws_mail_res_ldflag =
 claws_mail_deps =
 endif
 
-if BUILD_NEWADDRBOOK
-abook_headers = \
-       addressbook-dbus.h
-abook_source = \
+new_abook_source = \
        addressbook-dbus.c
+old_abook_source = \
+       addrbook.c \
+       addrclip.c \
+       addrcustomattr.c \
+       addressbook.c \
+       addressbook_foldersel.c \
+       addrindex.c \
+       addrquery.c \
+       addrselect.c \
+       addrduplicates.c \
+       browseldap.c \
+       editaddress.c \
+       editaddress_other_attributes_ldap.c \
+       editbook.c \
+       editgroup.c \
+       editjpilot.c \
+       editldap_basedn.c \
+       editldap.c \
+       editvcard.c \
+       exphtmldlg.c \
+       expldifdlg.c \
+       exporthtml.c \
+       exportldif.c \
+       importldif.c \
+       importmutt.c \
+       importpine.c \
+       jpilot.c \
+       ldapctrl.c \
+       ldaplocate.c \
+       ldapquery.c \
+       ldapserver.c \
+       ldapupdate.c \
+       ldaputil.c \
+       ldif.c \
+       mutt.c \
+       pine.c \
+       vcard.c
+
+if BUILD_NEWADDRBOOK
+abook_source = $(new_abook_source)
+abook_extra = $(old_abook_source)
 else
+abook_source = $(old_abook_source)
+abook_extra = $(new_abook_source)
+endif
+
 abook_headers = \
+       addressbook-dbus.h \
+       adbookbase.h \
        addrbook.h \
        addrclip.h \
        addrcustomattr.h \
@@ -58,6 +106,7 @@ abook_headers = \
        expldifdlg.h \
        exporthtml.h \
        exportldif.h \
+       file_checker.h \
        importldif.h \
        importmutt.h \
        importpine.h \
@@ -73,45 +122,6 @@ abook_headers = \
        pine.h \
        vcard.h
 
-abook_source = \
-       addrbook.c \
-       addrclip.c \
-       addrcustomattr.c \
-       addressbook.c \
-       addressbook_foldersel.c \
-       addrindex.c \
-       addrquery.c \
-       addrselect.c \
-       addrduplicates.c \
-       browseldap.c \
-       editaddress.c \
-       editaddress_other_attributes_ldap.c \
-       editbook.c \
-       editgroup.c \
-       editjpilot.c \
-       editldap_basedn.c \
-       editldap.c \
-       editvcard.c \
-       exphtmldlg.c \
-       expldifdlg.c \
-       exporthtml.c \
-       exportldif.c \
-       importldif.c \
-       importmutt.c \
-       importpine.c \
-       jpilot.c \
-       ldapctrl.c \
-       ldaplocate.c \
-       ldapquery.c \
-       ldapserver.c \
-       ldapupdate.c \
-       ldaputil.c \
-       ldif.c \
-       mutt.c \
-       pine.c \
-       vcard.c
-endif
-
 claws_mail_SOURCES = \
        account.c \
        action.c \
@@ -121,8 +131,10 @@ claws_mail_SOURCES = \
        addrgather.c \
        addrharvest.c \
        addritem.c \
+       advsearch.c \
        alertpanel.c \
        autofaces.c \
+       avatars.c \
        codeconv.c \
        compose.c \
        crash.c \
@@ -131,6 +143,7 @@ claws_mail_SOURCES = \
        edittags.c \
        enriched.c \
        export.c \
+        file_checker.c \
        filtering.c \
        folder.c \
        folder_item_prefs.c \
@@ -233,8 +246,10 @@ claws_mailinclude_HEADERS = \
        addressitem.h \
        addrgather.h \
        addrharvest.h \
+       advsearch.h \
        alertpanel.h \
        autofaces.h \
+       avatars.h \
        codeconv.h \
        compose.h \
        crash.h \
@@ -262,6 +277,7 @@ claws_mailinclude_HEADERS = \
        mainwindow.h \
        manual.h \
        matcher.h \
+       matchertypes.h \
        matcher_parser.h \
        matcher_parser_lex.h \
        matcher_parser_parse.h \
@@ -312,6 +328,7 @@ claws_mailinclude_HEADERS = \
        procheader.h \
        procmime.h \
        procmsg.h \
+       proctypes.h \
        quote_fmt.h \
        quote_fmt_lex.h \
        quote_fmt_parse.h \
@@ -330,6 +347,7 @@ claws_mailinclude_HEADERS = \
        undo.h \
        unmime.h \
        uri_opener.h \
+       viewtypes.h \
        wizard.h \
        $(abook_headers)
 
@@ -362,6 +380,7 @@ EXTRA_DIST = \
        pixmaps/check_spelling.xpm \
        pixmaps/clipkey.xpm \
        pixmaps/claws-mail_icon.xpm \
+       pixmaps/claws-mail_compose_logo.xpm \
        pixmaps/claws-mail_logo.xpm \
        pixmaps/claws-mail_logo-small.xpm \
        pixmaps/claws-mail.xpm \
@@ -510,10 +529,11 @@ EXTRA_DIST = \
        pixmaps/tray_unreadmarkedmail.xpm \
        pixmaps/empty.xpm \
        pixmaps/replied_and_forwarded.xpm \
-       claws-contacts.xml
+       claws-contacts.xml \
+       $(abook_extra)
 
 
-INCLUDES = \
+IFLAGS = \
        -I$(srcdir)/common \
        -Icommon \
        -I$(srcdir)/gtk \
@@ -538,7 +558,6 @@ claws_mail_LDADD = \
        $(ENCHANT_LIBS) \
        $(INTLLIBS) \
        $(GTK_LIBS) \
-       $(GPGME_LIBS) \
        $(LDAP_LIBS) \
        $(GNUTLS_LIBS) \
        $(COMPFACE_LIBS) \
@@ -548,8 +567,6 @@ claws_mail_LDADD = \
        $(LIBICONV) \
        $(STARTUP_NOTIFICATION_LIBS) \
        $(LIBETPAN_LIBS) \
-       $(MAEMO_LIBS) \
-       $(CONIC_LIBS) \
        $(DBUS_LIBS) \
        $(CONTACTS_LIBS)
 
@@ -560,17 +577,15 @@ AM_CPPFLAGS = \
        -DLOCALEDIR=\""$(localedir)"\" \
        -DPIXMAP_DIR=\""$(pixmapdir)"\" \
        -DMANUALDIR=\""$(manualdir)"\" \
-       -DFAQDIR=\""$(faqdir)"\" \
        -DTARGET_ALIAS=\""$(target_triplet)"\" \
        -DSYSCONFDIR=\""$(sysconfdir)"\" \
        -DDATAROOTDIR=\""$(datarootdir)"\" \
+       $(IFLAGS) \
        $(ENCHANT_CFLAGS) \
        $(GTK_CFLAGS) \
        $(GPGME_CFLAGS) \
        $(LIBETPAN_CPPFLAGS) \
        $(STARTUP_NOTIFICATION_CFLAGS) \
-       $(MAEMO_CFLAGS) \
-       $(CONIC_CFLAGS) \
        $(DBUS_CFLAGS) \
        $(NETWORKMANAGER_SUPPORT_CFLAGS) \
        $(VALGRIND_CFLAGS) \