indicate IMAP mailboxes which show subs only with a green folder
[claws.git] / src / Makefile.am
index a7ce5691a2b9979c86544edb98e74db1e96beb7d..d169c39cf468adf205ddcfb40aa7ce79a20d69e0 100644 (file)
@@ -1,3 +1,7 @@
+# Copyright 1999-2014 the Claws Mail team.
+# This file is part of Claws Mail package, and distributed under the
+# terms of the General Public License version 3 (or later).
+# See COPYING file for license details.
 
 if CLAWS_LIBETPAN
 etpan_dir = etpan
@@ -15,8 +19,8 @@ install-exec-hook:
        @ln -s claws-mail $(DESTDIR)$(bindir)/sylpheed-claws
 
 if PLATFORM_WIN32
-LTRCCOMPILE = $(LIBTOOL) --mode=compile $(RC) \
-     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RC) \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(IFLAGS) | \
      sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
 
 %.o : %.rc
@@ -29,9 +33,9 @@ claws_mail_res_ldflag =
 claws_mail_deps =
 endif
 
-new_abook_source = \
+alt_abook_source = \
        addressbook-dbus.c
-old_abook_source = \
+orig_abook_source = \
        addrbook.c \
        addrclip.c \
        addrcustomattr.c \
@@ -69,12 +73,12 @@ old_abook_source = \
        pine.c \
        vcard.c
 
-if BUILD_NEWADDRBOOK
-abook_source = $(new_abook_source)
-abook_extra = $(old_abook_source)
+if BUILD_ALTADDRBOOK
+abook_source = $(alt_abook_source)
+abook_extra = $(orig_abook_source)
 else
-abook_source = $(old_abook_source)
-abook_extra = $(new_abook_source)
+abook_source = $(orig_abook_source)
+abook_extra = $(alt_abook_source)
 endif
 
 abook_headers = \
@@ -102,6 +106,7 @@ abook_headers = \
        expldifdlg.h \
        exporthtml.h \
        exportldif.h \
+       file_checker.h \
        importldif.h \
        importmutt.h \
        importpine.h \
@@ -126,8 +131,10 @@ claws_mail_SOURCES = \
        addrgather.c \
        addrharvest.c \
        addritem.c \
+       advsearch.c \
        alertpanel.c \
        autofaces.c \
+       avatars.c \
        codeconv.c \
        compose.c \
        crash.c \
@@ -136,6 +143,7 @@ claws_mail_SOURCES = \
        edittags.c \
        enriched.c \
        export.c \
+        file_checker.c \
        filtering.c \
        folder.c \
        folder_item_prefs.c \
@@ -168,6 +176,9 @@ claws_mail_SOURCES = \
        news_gtk.c \
        noticeview.c \
        partial_download.c \
+       password.c \
+       password_gtk.c \
+       passwordstore.c \
        pop.c \
        prefs_account.c \
        prefs_actions.c \
@@ -185,6 +196,7 @@ claws_mail_SOURCES = \
        prefs_logging.c \
        prefs_matcher.c \
        prefs_message.c \
+       prefs_migration.c \
        prefs_msg_colors.c \
        prefs_other.c \
        prefs_quote.c \
@@ -211,7 +223,6 @@ claws_mail_SOURCES = \
        remotefolder.c \
        send_message.c \
        setup.c \
-       simple-gettext.c \
        sourcewindow.c \
        ssl_manager.c \
        statusbar.c \
@@ -238,8 +249,10 @@ claws_mailinclude_HEADERS = \
        addressitem.h \
        addrgather.h \
        addrharvest.h \
+       advsearch.h \
        alertpanel.h \
        autofaces.h \
+       avatars.h \
        codeconv.h \
        compose.h \
        crash.h \
@@ -267,6 +280,7 @@ claws_mailinclude_HEADERS = \
        mainwindow.h \
        manual.h \
        matcher.h \
+       matchertypes.h \
        matcher_parser.h \
        matcher_parser_lex.h \
        matcher_parser_parse.h \
@@ -281,6 +295,9 @@ claws_mailinclude_HEADERS = \
        news_gtk.h \
        noticeview.h \
        partial_download.h \
+       password.h \
+       password_gtk.h \
+       passwordstore.h \
        pop.h \
        prefs_account.h \
        prefs_actions.h \
@@ -298,6 +315,7 @@ claws_mailinclude_HEADERS = \
        prefs_logging.h \
        prefs_matcher.h \
        prefs_message.h \
+       prefs_migration.h \
        prefs_msg_colors.h \
        prefs_other.h \
        prefs_quote.h \
@@ -317,6 +335,7 @@ claws_mailinclude_HEADERS = \
        procheader.h \
        procmime.h \
        procmsg.h \
+       proctypes.h \
        quote_fmt.h \
        quote_fmt_lex.h \
        quote_fmt_parse.h \
@@ -335,6 +354,7 @@ claws_mailinclude_HEADERS = \
        undo.h \
        unmime.h \
        uri_opener.h \
+       viewtypes.h \
        wizard.h \
        $(abook_headers)
 
@@ -344,7 +364,7 @@ BUILT_SOURCES = \
        client-bindings.h
 
 client-bindings.h: claws-contacts.xml
-if BUILD_NEWADDRBOOK
+if BUILD_ALTADDRBOOK
        dbus-binding-tool --prefix=abook --mode=glib-client --output=$@ claws-contacts.xml
 
 CLEANFILES = \
@@ -367,6 +387,7 @@ EXTRA_DIST = \
        pixmaps/check_spelling.xpm \
        pixmaps/clipkey.xpm \
        pixmaps/claws-mail_icon.xpm \
+       pixmaps/claws-mail_compose_logo.xpm \
        pixmaps/claws-mail_logo.xpm \
        pixmaps/claws-mail_logo-small.xpm \
        pixmaps/claws-mail.xpm \
@@ -382,6 +403,10 @@ EXTRA_DIST = \
        pixmaps/dir_noselect.xpm \
        pixmaps/dir_open_hrm.xpm \
        pixmaps/dir_open.xpm \
+       pixmaps/dir_subs_close_mark.xpm \
+       pixmaps/dir_subs_close.xpm \
+       pixmaps/dir_subs_open_mark.xpm \
+       pixmaps/dir_subs_open.xpm \
        pixmaps/down_arrow.xpm \
        pixmaps/drafts_close.xpm \
        pixmaps/drafts_open.xpm \
@@ -519,20 +544,14 @@ EXTRA_DIST = \
        $(abook_extra)
 
 
-INCLUDES = \
+IFLAGS = \
        -I$(srcdir)/common \
        -Icommon \
        -I$(srcdir)/gtk \
        -I$(srcdir)/etpan
 
-if PLATFORM_WIN32
-arch_ldflags := -export-all-symbols
-else
-arch_ldflags :=
-endif
-
 claws_mail_LDFLAGS = \
-       $(arch_ldflags) -export-dynamic $(claws_mail_res_ldflag)
+       $(claws_mail_res_ldflag)
 
 claws_mail_DEPENDENCIES = $(claws_mail_deps) \
        $(etpan_library) \
@@ -544,7 +563,6 @@ claws_mail_LDADD = \
        $(ENCHANT_LIBS) \
        $(INTLLIBS) \
        $(GTK_LIBS) \
-       $(GPGME_LIBS) \
        $(LDAP_LIBS) \
        $(GNUTLS_LIBS) \
        $(COMPFACE_LIBS) \
@@ -554,8 +572,6 @@ claws_mail_LDADD = \
        $(LIBICONV) \
        $(STARTUP_NOTIFICATION_LIBS) \
        $(LIBETPAN_LIBS) \
-       $(MAEMO_LIBS) \
-       $(CONIC_LIBS) \
        $(DBUS_LIBS) \
        $(CONTACTS_LIBS)
 
@@ -566,17 +582,16 @@ AM_CPPFLAGS = \
        -DLOCALEDIR=\""$(localedir)"\" \
        -DPIXMAP_DIR=\""$(pixmapdir)"\" \
        -DMANUALDIR=\""$(manualdir)"\" \
-       -DFAQDIR=\""$(faqdir)"\" \
        -DTARGET_ALIAS=\""$(target_triplet)"\" \
        -DSYSCONFDIR=\""$(sysconfdir)"\" \
        -DDATAROOTDIR=\""$(datarootdir)"\" \
+       $(IFLAGS) \
        $(ENCHANT_CFLAGS) \
        $(GTK_CFLAGS) \
+       $(GNUTLS_CFLAGS) \
        $(GPGME_CFLAGS) \
        $(LIBETPAN_CPPFLAGS) \
        $(STARTUP_NOTIFICATION_CFLAGS) \
-       $(MAEMO_CFLAGS) \
-       $(CONIC_CFLAGS) \
        $(DBUS_CFLAGS) \
        $(NETWORKMANAGER_SUPPORT_CFLAGS) \
        $(VALGRIND_CFLAGS) \