revert
[claws.git] / src / Makefile.am
index add50ca4e259c32dff06fb6a8f66ea3c31770a4b..cee52c1d1875c6c87653850d2390e8fb449fe591 100644 (file)
@@ -25,7 +25,11 @@ sylpheed_SOURCES = \
        prefs_common.c prefs_common.h \
        prefs_filter.c prefs_filter.h \
        prefs_account.c prefs_account.h \
+       prefs_display_header.c prefs_display_header.h \
+       prefs_customheader.c prefs_customheader.h \
        account.c account.h \
+       displayheader.c displayheader.h \
+       customheader.c customheader.h \
        addressbook.c addressbook.h \
        filesel.c filesel.h \
        foldersel.c foldersel.h \
@@ -75,15 +79,28 @@ sylpheed_SOURCES = \
        addr_compl.c addr_compl.h \
        gtkstext.c gtkstext.h \
        grouplist_dialog.c grouplist_dialog.h \
-       customheader.c customheader.h \
-       prefs_headers.c prefs_headers.h \
-       headers_display.c headers_display.h \
-       prefs_display_headers.c prefs_display_headers.h \
        scoring.c scoring.h \
        prefs_folder_item.c prefs_folder_item.h \
-       matcher.c matcher.h
+       matcher.c matcher.h \
+       prefs_matcher.c prefs_matcher.h \
+       prefs_scoring.c prefs_scoring.h \
+       filtering.c filtering.h \
+       prefs_filtering.c prefs_filtering.h \
+       mbox_folder.c mbox_folder.h \
+       quote_fmt_lex.l quote_fmt_lex.h \
+       quote_fmt_parse.y quote_fmt.h \
+       addressitem.h \
+       mgutils.c mgutils.h \
+       vcard.c vcard.h \
+       jpilot.c jpilot.h \
+       syldap.c syldap.h \
+       editvcard.c editvcard.h \
+       editjpilot.c editjpilot.h \
+       editldap.c editldap.h \
+       editldap_basedn.c editldap_basedn.h
 
 EXTRA_DIST = \
+       quote_fmt_parse.h \
        pixmaps/clip.xpm \
        pixmaps/deleted.xpm \
        pixmaps/dir-close.xpm \
@@ -109,8 +126,10 @@ EXTRA_DIST = \
        pixmaps/stock_mail_receive_all.xpm \
        pixmaps/stock_mail_send.xpm \
        pixmaps/stock_mail_compose.xpm \
+       pixmaps/stock_news_compose.xpm \
        pixmaps/stock_mail_reply.xpm \
        pixmaps/stock_mail_reply_to_all.xpm \
+       pixmaps/stock_mail_reply_to_author.xpm \
        pixmaps/stock_mail_forward.xpm \
        pixmaps/stock_preferences.xpm \
        pixmaps/stock_properties.xpm \
@@ -122,7 +141,12 @@ EXTRA_DIST = \
        pixmaps/stock_down_arrow.xpm \
        pixmaps/stock_paste.xpm \
        pixmaps/tb_address_book.xpm \
-       pixmaps/sylpheed-logo.xpm
+       pixmaps/sylpheed-logo.xpm \
+       pixmaps/vcard.xpm \
+       pixmaps/jpilot.xpm \
+       pixmaps/category.xpm \
+       pixmaps/ldap.xpm \
+       pixmaps/ignorethread.xpm
 
 INCLUDES = \
        -DG_LOG_DOMAIN=\"Sylpheed\" \
@@ -144,4 +168,14 @@ sylpheed_LDADD = \
 CPPFLAGS = \
        -DLOCALEDIR=\""$(localedir)"\" \
        -DMANUALDIR=\""$(manualdir)"\" \
-       -DHOST_ALIAS=\""$(host_alias)"\"
+       -DHOST_ALIAS=\""$(host_alias)"\" \
+       -DSYSCONFDIR=\""$(sysconfdir)"\"
+
+YFLAGS = -d
+
+
+BUILT_SOURCES = \
+       quote_fmt_lex.c \
+       quote_fmt_parse.c \
+       quote_fmt_parse.h
+