2007-02-20 [colin] 2.7.2cvs58
[claws.git] / src / Makefile.am
index bac640abfbc6ba57de5fac50dec91e77d0d09cec..c3e85f5c2901c248695d4a4b6a20b8128ee8d5b8 100644 (file)
@@ -1,7 +1,7 @@
 
-if SYLPHEED_LIBETPAN
+if CLAWS_LIBETPAN
 etpan_dir = etpan
-etpan_library = etpan/libsylpheedetpan.la
+etpan_library = etpan/libclawsetpan.la
 else
 etpan_dir =
 etpan_library = 
@@ -9,9 +9,12 @@ endif
 
 SUBDIRS = common gtk $(etpan_dir) . plugins
 
-bin_PROGRAMS = sylpheed-claws
+bin_PROGRAMS = claws-mail
+install-exec-hook:
+       @rm -f $(DESTDIR)$(bindir)/sylpheed-claws
+       @ln -s claws-mail $(DESTDIR)$(bindir)/sylpheed-claws
 
-sylpheed_claws_SOURCES = \
+claws_mail_SOURCES = \
        account.c \
        action.c \
        addrbook.c \
@@ -20,6 +23,7 @@ sylpheed_claws_SOURCES = \
        addr_compl.c \
        addressadd.c \
        addressbook.c \
+       addressbook_foldersel.c \
        addrgather.c \
        addrharvest.c \
        addrindex.c \
@@ -142,11 +146,12 @@ sylpheed_claws_SOURCES = \
        toolbar.c \
        undo.c \
        unmime.c \
+       uri_opener.c \
        vcard.c \
        wizard.c
 
-sylpheed_clawsincludedir = $(pkgincludedir)
-sylpheed_clawsinclude_HEADERS = \
+claws_mailincludedir = $(pkgincludedir)
+claws_mailinclude_HEADERS = \
        account.h \
        action.h \
        adbookbase.h \
@@ -157,6 +162,7 @@ sylpheed_clawsinclude_HEADERS = \
        addrdefs.h \
        addressadd.h \
        addressbook.h \
+       addressbook_foldersel.h \
        addressitem.h \
        addrgather.h \
        addrharvest.h \
@@ -280,6 +286,7 @@ sylpheed_clawsinclude_HEADERS = \
        toolbar.h \
        undo.h \
        unmime.h \
+       uri_opener.h \
        vcard.h \
        wizard.h
 
@@ -288,6 +295,9 @@ BUILT_SOURCES = \
        quote_fmt_parse.h
 
 EXTRA_DIST = \
+       pixmaps/active.xpm \
+       pixmaps/addr_one.xpm \
+       pixmaps/addr_two.xpm \
        pixmaps/address_book.xpm \
        pixmaps/address_search.xpm \
        pixmaps/address.xpm \
@@ -317,6 +327,7 @@ EXTRA_DIST = \
        pixmaps/group.xpm \
        pixmaps/ham_btn.xpm \
        pixmaps/ignorethread.xpm \
+       pixmaps/inactive.xpm \
        pixmaps/inbox_hrm.xpm \
        pixmaps/inbox.xpm \
        pixmaps/interface.xpm \
@@ -342,6 +353,10 @@ EXTRA_DIST = \
        pixmaps/mime_audio.xpm \
        pixmaps/mime_image.xpm \
        pixmaps/mime_message.xpm \
+       pixmaps/mime_pdf.xpm \
+       pixmaps/mime_ps.xpm \
+       pixmaps/mime_calendar.xpm \
+       pixmaps/mime_pgpsig.xpm \
        pixmaps/mime_text_enriched.xpm \
        pixmaps/mime_text_html.xpm \
        pixmaps/mime_text_plain.xpm \
@@ -374,9 +389,9 @@ EXTRA_DIST = \
        pixmaps/search.xpm \
        pixmaps/spam.xpm \
        pixmaps/spam_btn.xpm \
-       pixmaps/sylpheed-claws_icon.xpm \
-       pixmaps/sylpheed-claws_logo.xpm \
-       pixmaps/sylpheed-claws.xpm \
+       pixmaps/claws-mail_icon.xpm \
+       pixmaps/claws-mail_logo.xpm \
+       pixmaps/claws-mail.xpm \
        pixmaps/trash_hrm.xpm \
        pixmaps/trash.xpm \
        pixmaps/trash_btn.xpm \
@@ -395,6 +410,8 @@ EXTRA_DIST = \
        pixmaps/outbox_mark.xpm \
        pixmaps/trash_hrm_mark.xpm \
        pixmaps/trash_mark.xpm \
+       pixmaps/moved.xpm \
+       pixmaps/copied.xpm \
        pixmaps/empty.xpm
 
 
@@ -409,12 +426,12 @@ else
 arch_ldflags :=
 endif
 
-sylpheed_claws_LDFLAGS = \
+claws_mail_LDFLAGS = \
        $(arch_ldflags) -export-dynamic
 
-sylpheed_claws_LDADD = \
+claws_mail_LDADD = \
        $(etpan_library) \
-       gtk/libsylpheedgtk.la \
+       gtk/libclawsgtk.la \
        $(ASPELL_LIBS) \
        $(INTLLIBS) \
        $(GTK_LIBS) \
@@ -425,12 +442,13 @@ sylpheed_claws_LDADD = \
        $(JPILOT_LIBS) \
        $(PTHREAD_LIBS) \
        $(GNOMEPRINT_LIBS) \
+       $(SM_LIBS) \
        $(LIBICONV) \
        $(STARTUP_NOTIFICATION_LIBS) \
        $(LIBETPAN_LIBS)
 
 AM_CPPFLAGS = \
-       -DG_LOG_DOMAIN=\"Sylpheed-Claws\" \
+       -DG_LOG_DOMAIN=\"Claws-Mail\" \
        -DLOCALEDIR=\""$(localedir)"\" \
        -DMANUALDIR=\""$(manualdir)"\" \
        -DFAQDIR=\""$(faqdir)"\" \
@@ -452,18 +470,18 @@ AM_CPPFLAGS = \
 AM_YFLAGS = -d
 
 if CYGWIN
-sylpheed-claws$(EXEEXT): $(sylpheed_claws_OBJECTS) $(sylpheed_claws_DEPENDENCIES) 
-       @rm -f sylpheed-claws$(EXEEXT)
-       @rm -f sylpheed-claws.def sylpheed-claws.base sylpheed-claws.exp libsylpheed-claws.a .libs/libsylpheed-claws.a
-       $(LINK) -shared $(sylpheed_clawsLDFLAGS) -Wl,--out-implib=libsylpheed-claws.a -Wl,--export-all-symbols,--exclude-symbols,main $(sylpheed_claws_OBJECTS) -Wl,--no-whole-archive $(sylpheed_claws_LDADD) $(LIBS)
-       dlltool --output-def sylpheed-claws.def --dllname sylpheed-claws$(EXEEXT) --export-all-symbols --exclude-symbols main $(sylpheed_claws_OBJECTS) gtk/.libs/libsylpheedgtk.a
-       $(LINK) $(sylpheed_claws_LDFLAGS) -Wl,--base-file,sylpheed-claws.base $(sylpheed_claws_OBJECTS) $(sylpheed_claws_LDADD) $(LIBS)
+claws-mail$(EXEEXT): $(claws_mail_OBJECTS) $(claws_mail_DEPENDENCIES) 
+       @rm -f claws-mail$(EXEEXT)
+       @rm -f claws-mail.def claws-mail.base claws-mail.exp libclaws-mail.a .libs/libclaws-mail.a
+       $(LINK) -shared $(claws_mailLDFLAGS) -Wl,--out-implib=libclaws-mail.a -Wl,--export-all-symbols,--exclude-symbols,main $(claws_mail_OBJECTS) -Wl,--no-whole-archive $(claws_mail_LDADD) $(LIBS)
+       dlltool --output-def claws-mail.def --dllname claws-mail$(EXEEXT) --export-all-symbols --exclude-symbols main $(claws_mail_OBJECTS) gtk/.libs/libclawsgtk.a
+       $(LINK) $(claws_mail_LDFLAGS) -Wl,--base-file,claws-mail.base $(claws_mail_OBJECTS) $(claws_mail_LDADD) $(LIBS)
        sleep 5
-       dlltool --base-file sylpheed-claws.base --input-def sylpheed-claws.def --output-exp sylpheed-claws.exp
-       $(LINK) $(sylpheed_claws_LDFLAGS) -Wl,sylpheed-claws.exp $(sylpheed_claws_OBJECTS) $(sylpheed_claws_LDADD) $(LIBS)
-       @cp libsylpheed-claws.a .libs/libsylpheed-claws.a
+       dlltool --base-file claws-mail.base --input-def claws-mail.def --output-exp claws-mail.exp
+       $(LINK) $(claws_mail_LDFLAGS) -Wl,claws-mail.exp $(claws_mail_OBJECTS) $(claws_mail_LDADD) $(LIBS)
+       @cp libclaws-mail.a .libs/libclaws-mail.a
 else
-#sylpheed-claws$(EXEEXT): $(sylpheed_claws_OBJECTS) $(sylpheed_claws_DEPENDENCIES) 
-#      @rm -f sylpheed-claws$(EXEEXT)
-#      $(LINK) $(sylpheed_claws_LDFLAGS) $(sylpheed_claws_OBJECTS) $(sylpheed_claws_LDADD) $(LIBS)
+#claws-mail$(EXEEXT): $(claws_mail_OBJECTS) $(claws_mail_DEPENDENCIES) 
+#      @rm -f claws-mail$(EXEEXT)
+#      $(LINK) $(claws_mail_LDFLAGS) $(claws_mail_OBJECTS) $(claws_mail_LDADD) $(LIBS)
 endif