2007-02-20 [colin] 2.7.2cvs58
[claws.git] / src / Makefile.am
index 96a84000e37f2163bb61cf584da94f24991de1bb..c3e85f5c2901c248695d4a4b6a20b8128ee8d5b8 100644 (file)
@@ -1,8 +1,20 @@
-SUBDIRS = common gtk plugins
 
-bin_PROGRAMS = sylpheed
+if CLAWS_LIBETPAN
+etpan_dir = etpan
+etpan_library = etpan/libclawsetpan.la
+else
+etpan_dir =
+etpan_library = 
+endif
 
-sylpheed_SOURCES = \
+SUBDIRS = common gtk $(etpan_dir) . plugins
+
+bin_PROGRAMS = claws-mail
+install-exec-hook:
+       @rm -f $(DESTDIR)$(bindir)/sylpheed-claws
+       @ln -s claws-mail $(DESTDIR)$(bindir)/sylpheed-claws
+
+claws_mail_SOURCES = \
        account.c \
        action.c \
        addrbook.c \
@@ -11,6 +23,7 @@ sylpheed_SOURCES = \
        addr_compl.c \
        addressadd.c \
        addressbook.c \
+       addressbook_foldersel.c \
        addrgather.c \
        addrharvest.c \
        addrindex.c \
@@ -43,6 +56,7 @@ sylpheed_SOURCES = \
        foldersel.c \
        folderutils.c \
        folderview.c \
+       gedit-print.c \
        grouplistdialog.c \
        headerview.c \
        html.c \
@@ -96,10 +110,16 @@ sylpheed_SOURCES = \
        prefs_gtk.c \
        prefs_image_viewer.c \
        prefs_matcher.c \
+       prefs_message.c \
        prefs_msg_colors.c \
+       prefs_other.c \
        prefs_quote.c \
+       prefs_receive.c \
+       prefs_send.c \
        prefs_spelling.c \
+       prefs_summaries.c \
        prefs_summary_column.c \
+       prefs_folder_column.c \
        prefs_template.c \
        prefs_themes.c \
        prefs_toolbar.c \
@@ -126,11 +146,12 @@ sylpheed_SOURCES = \
        toolbar.c \
        undo.c \
        unmime.c \
+       uri_opener.c \
        vcard.c \
        wizard.c
 
-sylpheedincludedir = $(pkgincludedir)
-sylpheedinclude_HEADERS = \
+claws_mailincludedir = $(pkgincludedir)
+claws_mailinclude_HEADERS = \
        account.h \
        action.h \
        adbookbase.h \
@@ -141,6 +162,7 @@ sylpheedinclude_HEADERS = \
        addrdefs.h \
        addressadd.h \
        addressbook.h \
+       addressbook_foldersel.h \
        addressitem.h \
        addrgather.h \
        addrharvest.h \
@@ -174,6 +196,7 @@ sylpheedinclude_HEADERS = \
        foldersel.h \
        folderutils.h \
        folderview.h \
+       gedit-print.h \
        grouplistdialog.h \
        headerview.h \
        html.h \
@@ -228,10 +251,16 @@ sylpheedinclude_HEADERS = \
        prefs_gtk.h \
        prefs_image_viewer.h \
        prefs_matcher.h \
+       prefs_message.h \
        prefs_msg_colors.h \
+       prefs_other.h \
        prefs_quote.h \
+       prefs_receive.h \
+       prefs_send.h \
        prefs_spelling.h \
+       prefs_summaries.h \
        prefs_summary_column.h \
+       prefs_folder_column.h \
        prefs_template.h \
        prefs_themes.h \
        prefs_toolbar.h \
@@ -257,6 +286,7 @@ sylpheedinclude_HEADERS = \
        toolbar.h \
        undo.h \
        unmime.h \
+       uri_opener.h \
        vcard.h \
        wizard.h
 
@@ -265,6 +295,9 @@ BUILT_SOURCES = \
        quote_fmt_parse.h
 
 EXTRA_DIST = \
+       pixmaps/active.xpm \
+       pixmaps/addr_one.xpm \
+       pixmaps/addr_two.xpm \
        pixmaps/address_book.xpm \
        pixmaps/address_search.xpm \
        pixmaps/address.xpm \
@@ -292,7 +325,9 @@ EXTRA_DIST = \
        pixmaps/forwarded.xpm \
        pixmaps/gpg_signed.xpm \
        pixmaps/group.xpm \
+       pixmaps/ham_btn.xpm \
        pixmaps/ignorethread.xpm \
+       pixmaps/inactive.xpm \
        pixmaps/inbox_hrm.xpm \
        pixmaps/inbox.xpm \
        pixmaps/interface.xpm \
@@ -318,6 +353,10 @@ EXTRA_DIST = \
        pixmaps/mime_audio.xpm \
        pixmaps/mime_image.xpm \
        pixmaps/mime_message.xpm \
+       pixmaps/mime_pdf.xpm \
+       pixmaps/mime_ps.xpm \
+       pixmaps/mime_calendar.xpm \
+       pixmaps/mime_pgpsig.xpm \
        pixmaps/mime_text_enriched.xpm \
        pixmaps/mime_text_html.xpm \
        pixmaps/mime_text_plain.xpm \
@@ -348,25 +387,51 @@ EXTRA_DIST = \
        pixmaps/quicksearch.xpm \
        pixmaps/replied.xpm \
        pixmaps/search.xpm \
-       pixmaps/sylpheed_icon.xpm \
-       pixmaps/sylpheed_logo.xpm \
-       pixmaps/sylpheed.xpm \
+       pixmaps/spam.xpm \
+       pixmaps/spam_btn.xpm \
+       pixmaps/claws-mail_icon.xpm \
+       pixmaps/claws-mail_logo.xpm \
+       pixmaps/claws-mail.xpm \
        pixmaps/trash_hrm.xpm \
        pixmaps/trash.xpm \
+       pixmaps/trash_btn.xpm \
        pixmaps/unread.xpm \
        pixmaps/read.xpm \
        pixmaps/up_arrow.xpm \
-       pixmaps/vcard.xpm
+       pixmaps/vcard.xpm \
+       pixmaps/dir_close_mark.xpm \
+       pixmaps/dir_open_hrm_mark.xpm \
+       pixmaps/dir_open_mark.xpm \
+       pixmaps/drafts_close_mark.xpm \
+       pixmaps/drafts_open_mark.xpm \
+       pixmaps/inbox_hrm_mark.xpm \
+       pixmaps/inbox_mark.xpm \
+       pixmaps/outbox_hrm_mark.xpm \
+       pixmaps/outbox_mark.xpm \
+       pixmaps/trash_hrm_mark.xpm \
+       pixmaps/trash_mark.xpm \
+       pixmaps/moved.xpm \
+       pixmaps/copied.xpm \
+       pixmaps/empty.xpm
+
 
 INCLUDES = \
-       -Icommon \
-       -Igtk
+       -I$(srcdir)/common \
+       -I$(srcdir)/gtk \
+       -I$(srcdir)/etpan
 
-sylpheed_LDFLAGS = \
-       -export-dynamic
+if PLATFORM_WIN32
+arch_ldflags := -export-all-symbols
+else
+arch_ldflags :=
+endif
 
-sylpheed_LDADD = \
-       gtk/libsylpheedgtk.la \
+claws_mail_LDFLAGS = \
+       $(arch_ldflags) -export-dynamic
+
+claws_mail_LDADD = \
+       $(etpan_library) \
+       gtk/libclawsgtk.la \
        $(ASPELL_LIBS) \
        $(INTLLIBS) \
        $(GTK_LIBS) \
@@ -376,11 +441,14 @@ sylpheed_LDADD = \
        $(COMPFACE_LIBS) \
        $(JPILOT_LIBS) \
        $(PTHREAD_LIBS) \
+       $(GNOMEPRINT_LIBS) \
+       $(SM_LIBS) \
        $(LIBICONV) \
-       $(STARTUP_NOTIFICATION_LIBS)
+       $(STARTUP_NOTIFICATION_LIBS) \
+       $(LIBETPAN_LIBS)
 
 AM_CPPFLAGS = \
-       -DG_LOG_DOMAIN=\"Sylpheed\" \
+       -DG_LOG_DOMAIN=\"Claws-Mail\" \
        -DLOCALEDIR=\""$(localedir)"\" \
        -DMANUALDIR=\""$(manualdir)"\" \
        -DFAQDIR=\""$(faqdir)"\" \
@@ -390,6 +458,30 @@ AM_CPPFLAGS = \
        $(GTK_CFLAGS) \
        $(GPGME_CFLAGS) \
        $(OPENSSL_CFLAGS) \
-       $(STARTUP_NOTIFICATION_CFLAGS)
+       $(GNOMEPRINT_CFLAGS) \
+       $(LIBETPAN_CPPFLAGS) \
+       $(STARTUP_NOTIFICATION_CFLAGS) \
+       -Wno-unused-function
+        
+#no-unused-function is there because of bison stuff
+#no-deprecated-declarations because of gpgme_data_rewind, which we have
+#to call inside gpgme due to our lack of LARGEFILE support
 
 AM_YFLAGS = -d
+
+if CYGWIN
+claws-mail$(EXEEXT): $(claws_mail_OBJECTS) $(claws_mail_DEPENDENCIES) 
+       @rm -f claws-mail$(EXEEXT)
+       @rm -f claws-mail.def claws-mail.base claws-mail.exp libclaws-mail.a .libs/libclaws-mail.a
+       $(LINK) -shared $(claws_mailLDFLAGS) -Wl,--out-implib=libclaws-mail.a -Wl,--export-all-symbols,--exclude-symbols,main $(claws_mail_OBJECTS) -Wl,--no-whole-archive $(claws_mail_LDADD) $(LIBS)
+       dlltool --output-def claws-mail.def --dllname claws-mail$(EXEEXT) --export-all-symbols --exclude-symbols main $(claws_mail_OBJECTS) gtk/.libs/libclawsgtk.a
+       $(LINK) $(claws_mail_LDFLAGS) -Wl,--base-file,claws-mail.base $(claws_mail_OBJECTS) $(claws_mail_LDADD) $(LIBS)
+       sleep 5
+       dlltool --base-file claws-mail.base --input-def claws-mail.def --output-exp claws-mail.exp
+       $(LINK) $(claws_mail_LDFLAGS) -Wl,claws-mail.exp $(claws_mail_OBJECTS) $(claws_mail_LDADD) $(LIBS)
+       @cp libclaws-mail.a .libs/libclaws-mail.a
+else
+#claws-mail$(EXEEXT): $(claws_mail_OBJECTS) $(claws_mail_DEPENDENCIES) 
+#      @rm -f claws-mail$(EXEEXT)
+#      $(LINK) $(claws_mail_LDFLAGS) $(claws_mail_OBJECTS) $(claws_mail_LDADD) $(LIBS)
+endif