move External Program prefs to Other Prefs
[claws.git] / src / Makefile.am
index 17ecbe89366afd19ee2b25bc92ebc82fcee8825c..bbdfe3787630a73c4883bde5ccbb889a2720dad7 100644 (file)
@@ -18,6 +18,7 @@ sylpheed_SOURCES = \
        addrquery.c \
        addrselect.c \
        alertpanel.c \
+       browseldap.c \
        codeconv.c \
        compose.c \
        crash.c \
@@ -53,6 +54,7 @@ sylpheed_SOURCES = \
        inputdialog.c \
        jpilot.c \
        ldapctrl.c \
+       ldaplocate.c \
        ldapquery.c \
        ldapserver.c \
        ldaputil.c \
@@ -81,14 +83,15 @@ sylpheed_SOURCES = \
        prefs_common.c \
        prefs_customheader.c \
        prefs_display_header.c \
+       prefs_ext_prog.c \
        prefs_filtering_action.c \
        prefs_filtering.c \
        prefs_folder_item.c \
        prefs_fonts.c \
        prefs_gtk.c \
        prefs_matcher.c \
-       prefs_scoring.c \
        prefs_spelling.c \
+       prefs_themes.c \
        prefs_summary_column.c \
        prefs_template.c \
        prefs_toolbar.c \
@@ -101,12 +104,10 @@ sylpheed_SOURCES = \
        quote_fmt_parse.y \
        recv.c \
        rfc2015.c \
-       scoring.c \
        select-keys.c \
        send_message.c \
        setup.c \
        sgpgme.c \
-       sigstatus.c \
        simple-gettext.c \
        sourcewindow.c \
        ssl_manager.c \
@@ -119,6 +120,8 @@ sylpheed_SOURCES = \
        toolbar.c \
        undo.c \
        unmime.c \
+       localfolder.c \
+       remotefolder.c \
        vcard.c
 
 sylpheedincludedir = $(pkgincludedir)
@@ -130,6 +133,7 @@ sylpheedinclude_HEADERS = \
        addrcache.h \
        addrclip.h \
        addr_compl.h \
+       addrdefs.h \
        addressadd.h \
        addressbook.h \
        addressitem.h \
@@ -140,6 +144,7 @@ sylpheedinclude_HEADERS = \
        addrquery.h \
        addrselect.h \
        alertpanel.h \
+       browseldap.h \
        codeconv.h \
        compose.h \
        crash.h \
@@ -175,6 +180,7 @@ sylpheedinclude_HEADERS = \
        inputdialog.h \
        jpilot.h \
        ldapctrl.h \
+       ldaplocate.h \
        ldapquery.h \
        ldapserver.h \
        ldaputil.h \
@@ -204,14 +210,15 @@ sylpheedinclude_HEADERS = \
        prefs_common.h \
        prefs_customheader.h \
        prefs_display_header.h \
+       prefs_ext_prog.h \
        prefs_filtering_action.h \
        prefs_filtering.h \
        prefs_folder_item.h \
        prefs_fonts.h \
        prefs_gtk.h \
        prefs_matcher.h \
-       prefs_scoring.h \
        prefs_spelling.h \
+       prefs_themes.h \
        prefs_summary_column.h \
        prefs_template.h \
        prefs_toolbar.h \
@@ -224,12 +231,10 @@ sylpheedinclude_HEADERS = \
        quote_fmt_parse.h \
        recv.h \
        rfc2015.h \
-       scoring.h \
        select-keys.h \
        send_message.h \
        setup.h \
        sgpgme.h \
-       sigstatus.h \
        sourcewindow.h \
        ssl_manager.h \
        statusbar.h \
@@ -241,6 +246,8 @@ sylpheedinclude_HEADERS = \
        toolbar.h \
        undo.h \
        unmime.h \
+       localfolder.h \
+       remotefolder.h \
        vcard.h
 
 BUILT_SOURCES = \
@@ -255,6 +262,7 @@ EXTRA_DIST = \
        pixmaps/category.xpm \
        pixmaps/checkbox_off.xpm \
        pixmaps/checkbox_on.xpm \
+       pixmaps/check_spelling.xpm \
        pixmaps/clipkey.xpm \
        pixmaps/clip.xpm \
        pixmaps/close.xpm \
@@ -297,6 +305,7 @@ EXTRA_DIST = \
        pixmaps/mime_application.xpm \
        pixmaps/mime_audio.xpm \
        pixmaps/mime_image.xpm \
+       pixmaps/mime_message.xpm \
        pixmaps/mime_text_enriched.xpm \
        pixmaps/mime_text_html.xpm \
        pixmaps/mime_text_plain.xpm \
@@ -306,6 +315,8 @@ EXTRA_DIST = \
        pixmaps/notice_error.xpm \
        pixmaps/notice_note.xpm \
        pixmaps/notice_warn.xpm \
+       pixmaps/offline.xpm \
+       pixmaps/online.xpm \
        pixmaps/outbox_hrm.xpm \
        pixmaps/outbox.xpm \
        pixmaps/paste.xpm \
@@ -327,9 +338,7 @@ EXTRA_DIST = \
        pixmaps/trash.xpm \
        pixmaps/unread.xpm \
        pixmaps/up_arrow.xpm \
-       pixmaps/vcard.xpm \
-       pixmaps/work_offline.xpm \
-       pixmaps/work_online.xpm
+       pixmaps/vcard.xpm
 
 INCLUDES = \
        -Icommon \
@@ -347,6 +356,8 @@ sylpheed_LDADD = \
        $(GPGME_LIBS) \
        $(LDAP_LIBS) \
        $(OPENSSL_LIBS) \
+       $(COMPFACE_LIBS) \
+       $(JPILOT_LIBS) \
        $(LIBICONV)
 
 AM_CPPFLAGS = \