2011-02-23 [colin] 3.7.8cvs59
[claws.git] / src / Makefile.am
index 5f3ff4bbf68ce2b967d45ad6a07bda080dea1c08..ba0af16dbde6df75e925c87379f9c41136545d3f 100644 (file)
@@ -7,13 +7,28 @@ etpan_dir =
 etpan_library = 
 endif
 
-SUBDIRS = common gtk $(etpan_dir) . plugins
+SUBDIRS = common gtk $(etpan_dir) . plugins 
 
 bin_PROGRAMS = claws-mail
 install-exec-hook:
        @rm -f $(DESTDIR)$(bindir)/sylpheed-claws
        @ln -s claws-mail $(DESTDIR)$(bindir)/sylpheed-claws
 
+if PLATFORM_WIN32
+LTRCCOMPILE = $(LIBTOOL) --mode=compile $(RC) \
+     `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
+     sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
+
+%.o : %.rc
+       $(LTRCCOMPILE) -i $< -o $@
+
+claws_mail_res_ldflag = -Wl,w32-resource.o
+claws_mail_deps = w32-resource.o
+else
+claws_mail_res_ldflag =
+claws_mail_deps =
+endif
+
 claws_mail_SOURCES = \
        account.c \
        action.c \
@@ -21,6 +36,7 @@ claws_mail_SOURCES = \
        addrcache.c \
        addrclip.c \
        addr_compl.c \
+       addrcustomattr.c \
        addressadd.c \
        addressbook.c \
        addressbook_foldersel.c \
@@ -30,7 +46,9 @@ claws_mail_SOURCES = \
        addritem.c \
        addrquery.c \
        addrselect.c \
+       addrduplicates.c \
        alertpanel.c \
+       autofaces.c \
        browseldap.c \
        codeconv.c \
        compose.c \
@@ -38,11 +56,13 @@ claws_mail_SOURCES = \
        customheader.c \
        displayheader.c \
        editaddress.c \
+       editaddress_other_attributes_ldap.c \
        editbook.c \
        editgroup.c \
        editjpilot.c \
        editldap_basedn.c \
        editldap.c \
+       edittags.c \
        editvcard.c \
        enriched.c \
        exphtmldlg.c \
@@ -56,7 +76,6 @@ claws_mail_SOURCES = \
        foldersel.c \
        folderutils.c \
        folderview.c \
-       gedit-print.c \
        grouplistdialog.c \
        headerview.c \
        html.c \
@@ -73,6 +92,7 @@ claws_mail_SOURCES = \
        ldaplocate.c \
        ldapquery.c \
        ldapserver.c \
+       ldapupdate.c \
        ldaputil.c \
        ldif.c \
        localfolder.c \
@@ -120,11 +140,13 @@ claws_mail_SOURCES = \
        prefs_spelling.c \
        prefs_summaries.c \
        prefs_summary_column.c \
+       prefs_summary_open.c \
        prefs_folder_column.c \
        prefs_template.c \
        prefs_themes.c \
        prefs_toolbar.c \
        prefs_wrapping.c \
+       printing.c \
        privacy.c \
        procheader.c \
        procmime.c \
@@ -161,6 +183,7 @@ claws_mailinclude_HEADERS = \
        addrclip.h \
        addr_compl.h \
        addrdefs.h \
+       addrcustomattr.h \
        addressadd.h \
        addressbook.h \
        addressbook_foldersel.h \
@@ -171,7 +194,9 @@ claws_mailinclude_HEADERS = \
        addritem.h \
        addrquery.h \
        addrselect.h \
+       addrduplicates.h \
        alertpanel.h \
+       autofaces.h \
        browseldap.h \
        codeconv.h \
        compose.h \
@@ -179,11 +204,13 @@ claws_mailinclude_HEADERS = \
        customheader.h \
        displayheader.h \
        editaddress.h \
+       editaddress_other_attributes_ldap.h \
        editbook.h \
        editgroup.h \
        editjpilot.h \
        editldap_basedn.h \
        editldap.h \
+       edittags.h \
        editvcard.h \
        enriched.h \
        exphtmldlg.h \
@@ -197,7 +224,6 @@ claws_mailinclude_HEADERS = \
        foldersel.h \
        folderutils.h \
        folderview.h \
-       gedit-print.h \
        grouplistdialog.h \
        headerview.h \
        html.h \
@@ -214,6 +240,7 @@ claws_mailinclude_HEADERS = \
        ldaplocate.h \
        ldapquery.h \
        ldapserver.h \
+       ldapupdate.h \
        ldaputil.h \
        ldif.h \
        localfolder.h \
@@ -262,11 +289,13 @@ claws_mailinclude_HEADERS = \
        prefs_spelling.h \
        prefs_summaries.h \
        prefs_summary_column.h \
+       prefs_summary_open.h \
        prefs_folder_column.h \
        prefs_template.h \
        prefs_themes.h \
        prefs_toolbar.h \
        prefs_wrapping.h \
+       printing.h \
        privacy.h \
        procheader.h \
        procmime.h \
@@ -297,44 +326,59 @@ BUILT_SOURCES = \
        quote_fmt_parse.h
 
 EXTRA_DIST = \
-       pixmaps/active.xpm \
+       w32-logo.ico w32-resource.rc \
        pixmaps/addr_one.xpm \
        pixmaps/addr_two.xpm \
        pixmaps/address_book.xpm \
        pixmaps/address_search.xpm \
        pixmaps/address.xpm \
+       pixmaps/anonymous.xpm \
        pixmaps/book.xpm \
+       pixmaps/cancel.xpm \
        pixmaps/category.xpm \
        pixmaps/checkbox_off.xpm \
        pixmaps/checkbox_on.xpm \
        pixmaps/check_spelling.xpm \
        pixmaps/clipkey.xpm \
+       pixmaps/claws-mail_icon.xpm \
+       pixmaps/claws-mail_logo.xpm \
+       pixmaps/claws-mail_logo-small.xpm \
+       pixmaps/claws-mail.xpm \
        pixmaps/clip.xpm \
        pixmaps/clip_gpg_signed.xpm \
        pixmaps/close.xpm \
        pixmaps/complete.xpm \
        pixmaps/continue.xpm \
+       pixmaps/delete_btn.xpm \
        pixmaps/deleted.xpm \
        pixmaps/dir_close.xpm \
+       pixmaps/dir_close_hrm.xpm \
        pixmaps/dir_noselect.xpm \
-        pixmaps/dir_open_hrm.xpm \
+       pixmaps/dir_open_hrm.xpm \
        pixmaps/dir_open.xpm \
        pixmaps/down_arrow.xpm \
        pixmaps/drafts_close.xpm \
        pixmaps/drafts_open.xpm \
+       pixmaps/drafts_close.xpm \
+       pixmaps/drafts_open.xpm \
+       pixmaps/edit_extern.xpm \
        pixmaps/error.xpm \
        pixmaps/exec.xpm \
        pixmaps/forwarded.xpm \
        pixmaps/gpg_signed.xpm \
+       pixmaps/go_folders.xpm \
        pixmaps/group.xpm \
        pixmaps/ham_btn.xpm \
        pixmaps/ignorethread.xpm \
-       pixmaps/inactive.xpm \
-       pixmaps/inbox_hrm.xpm \
-       pixmaps/inbox.xpm \
+       pixmaps/inbox_open_hrm.xpm \
+       pixmaps/inbox_open.xpm \
+       pixmaps/inbox_close_hrm.xpm \
+       pixmaps/inbox_close.xpm \
        pixmaps/interface.xpm \
+       pixmaps/insert_file.xpm \
        pixmaps/jpilot.xpm \
        pixmaps/key.xpm \
+       pixmaps/key_gpg_signed.xpm \
        pixmaps/ldap.xpm \
        pixmaps/linewrap.xpm \
        pixmaps/linewrapcurrent.xpm \
@@ -346,9 +390,11 @@ EXTRA_DIST = \
        pixmaps/mail_receive.xpm \
        pixmaps/mail_reply_to_all.xpm \
        pixmaps/mail_reply_to_author.xpm \
+       pixmaps/mail_reply_to_list.xpm \
        pixmaps/mail_reply.xpm \
        pixmaps/mail_send_queue.xpm \
        pixmaps/mail_send.xpm \
+       pixmaps/mail_sign.xpm \
        pixmaps/mail.xpm \
        pixmaps/mark.xpm \
        pixmaps/mime_application.xpm \
@@ -361,6 +407,7 @@ EXTRA_DIST = \
        pixmaps/mime_pgpsig.xpm \
        pixmaps/mime_text_enriched.xpm \
        pixmaps/mime_text_html.xpm \
+       pixmaps/mime_text_patch.xpm \
        pixmaps/mime_text_plain.xpm \
        pixmaps/mime_unknown.xpm \
        pixmaps/news_compose.xpm \
@@ -370,10 +417,18 @@ EXTRA_DIST = \
        pixmaps/notice_warn.xpm \
        pixmaps/offline.xpm \
        pixmaps/online.xpm \
-       pixmaps/outbox_hrm.xpm \
-       pixmaps/outbox.xpm \
+       pixmaps/open_mail.xpm \
+       pixmaps/outbox_close.xpm \
+       pixmaps/outbox_close_hrm.xpm \
+       pixmaps/outbox_open.xpm \
+       pixmaps/outbox_open_hrm.xpm \
+       pixmaps/outbox_close_mark.xpm \
+       pixmaps/outbox_close_hrm_mark.xpm \
+       pixmaps/outbox_open_mark.xpm \
+       pixmaps/outbox_open_hrm_mark.xpm \
        pixmaps/paste.xpm \
        pixmaps/preferences.xpm \
+       pixmaps/printer.xpm \
        pixmaps/privacy_expired.xpm \
        pixmaps/privacy_failed.xpm \
        pixmaps/privacy_passed.xpm \
@@ -386,14 +441,20 @@ EXTRA_DIST = \
        pixmaps/privacy_emblem_signed.xpm \
        pixmaps/privacy_emblem_warn.xpm \
        pixmaps/properties.xpm \
+       pixmaps/queue_close.xpm \
+       pixmaps/queue_close_hrm.xpm \
+       pixmaps/queue_close_hrm_mark.xpm \
+       pixmaps/queue_close_mark.xpm \
+       pixmaps/queue_open.xpm \
+       pixmaps/queue_open_hrm.xpm \
+       pixmaps/queue_open_hrm_mark.xpm \
+       pixmaps/queue_open_mark.xpm \
        pixmaps/quicksearch.xpm \
        pixmaps/replied.xpm \
        pixmaps/search.xpm \
+       pixmaps/selection.xpm \
        pixmaps/spam.xpm \
        pixmaps/spam_btn.xpm \
-       pixmaps/claws-mail_icon.xpm \
-       pixmaps/claws-mail_logo.xpm \
-       pixmaps/claws-mail.xpm \
        pixmaps/trash_hrm.xpm \
        pixmaps/trash.xpm \
        pixmaps/trash_btn.xpm \
@@ -402,23 +463,36 @@ EXTRA_DIST = \
        pixmaps/up_arrow.xpm \
        pixmaps/vcard.xpm \
        pixmaps/dir_close_mark.xpm \
+       pixmaps/dir_close_hrm_mark.xpm \
        pixmaps/dir_open_hrm_mark.xpm \
        pixmaps/dir_open_mark.xpm \
        pixmaps/drafts_close_mark.xpm \
        pixmaps/drafts_open_mark.xpm \
-       pixmaps/inbox_hrm_mark.xpm \
-       pixmaps/inbox_mark.xpm \
-       pixmaps/outbox_hrm_mark.xpm \
-       pixmaps/outbox_mark.xpm \
+       pixmaps/inbox_open_hrm_mark.xpm \
+       pixmaps/inbox_open_mark.xpm \
+       pixmaps/inbox_close_hrm_mark.xpm \
+       pixmaps/inbox_close_mark.xpm \
        pixmaps/trash_hrm_mark.xpm \
        pixmaps/trash_mark.xpm \
        pixmaps/moved.xpm \
        pixmaps/copied.xpm \
+       pixmaps/watchthread.xpm \
+       pixmaps/tray_newmail.offline.xpm \
+       pixmaps/tray_newmail.xpm \
+       pixmaps/tray_newmarkedmail.offline.xpm \
+       pixmaps/tray_newmarkedmail.xpm \
+       pixmaps/tray_nomail.offline.xpm \
+       pixmaps/tray_nomail.xpm \
+       pixmaps/tray_unreadmail.offline.xpm \
+       pixmaps/tray_unreadmail.xpm \
+       pixmaps/tray_unreadmarkedmail.offline.xpm \
+       pixmaps/tray_unreadmarkedmail.xpm \
        pixmaps/empty.xpm
 
 
 INCLUDES = \
        -I$(srcdir)/common \
+       -Icommon \
        -I$(srcdir)/gtk \
        -I$(srcdir)/etpan
 
@@ -429,45 +503,54 @@ arch_ldflags :=
 endif
 
 claws_mail_LDFLAGS = \
-       $(arch_ldflags) -export-dynamic
+       $(arch_ldflags) -export-dynamic $(claws_mail_res_ldflag)
+
+claws_mail_DEPENDENCIES = $(claws_mail_deps) \
+       $(etpan_library) \
+       gtk/libclawsgtk.la
 
 claws_mail_LDADD = \
        $(etpan_library) \
        gtk/libclawsgtk.la \
-       $(ASPELL_LIBS) \
+       $(ENCHANT_LIBS) \
        $(INTLLIBS) \
        $(GTK_LIBS) \
        $(GPGME_LIBS) \
        $(LDAP_LIBS) \
-       $(OPENSSL_LIBS) \
+       $(GNUTLS_LIBS) \
        $(COMPFACE_LIBS) \
        $(JPILOT_LIBS) \
        $(PTHREAD_LIBS) \
-       $(GNOMEPRINT_LIBS) \
        $(SM_LIBS) \
        $(LIBICONV) \
        $(STARTUP_NOTIFICATION_LIBS) \
        $(LIBETPAN_LIBS) \
-       $(MAEMO_LIBS)
+       $(MAEMO_LIBS) \
+       $(CONIC_LIBS) \
+       $(DBUS_LIBS)
+
+pixmapdir=$(datadir)/icons/hicolor/48x48/apps
 
 AM_CPPFLAGS = \
        -DG_LOG_DOMAIN=\"Claws-Mail\" \
        -DLOCALEDIR=\""$(localedir)"\" \
+       -DPIXMAP_DIR=\""$(pixmapdir)"\" \
        -DMANUALDIR=\""$(manualdir)"\" \
        -DFAQDIR=\""$(faqdir)"\" \
        -DTARGET_ALIAS=\""$(target_triplet)"\" \
        -DSYSCONFDIR=\""$(sysconfdir)"\" \
        -DDATAROOTDIR=\""$(datarootdir)"\" \
-       $(ASPELL_CFLAGS) \
+       $(ENCHANT_CFLAGS) \
        $(GTK_CFLAGS) \
        $(GPGME_CFLAGS) \
-       $(OPENSSL_CFLAGS) \
-       $(GNOMEPRINT_CFLAGS) \
        $(LIBETPAN_CPPFLAGS) \
        $(STARTUP_NOTIFICATION_CFLAGS) \
        $(MAEMO_CFLAGS) \
-       -Wno-unused-function
-        
+       $(CONIC_CFLAGS) \
+       $(DBUS_CFLAGS) \
+       $(NETWORKMANAGER_SUPPORT_CFLAGS) \
+       $(VALGRIND_CFLAGS)
+
 #no-unused-function is there because of bison stuff
 #no-deprecated-declarations because of gpgme_data_rewind, which we have
 #to call inside gpgme due to our lack of LARGEFILE support