make return receipts work again
[claws.git] / src / Makefile.am
index 94ac7ba6402cef8df457db6d548f301f213aecb3..b66fb1570f20e4388b18e7ed9c61b6d61cf11fc1 100644 (file)
@@ -35,6 +35,7 @@ sylpheed_SOURCES = \
        prefs_customheader.c prefs_customheader.h \
        prefs_summary_column.c prefs_summary_column.h \
        prefs_template.c prefs_template.h \
+       prefs_actions.c prefs_actions.h \
        account.c account.h \
        displayheader.c displayheader.h \
        customheader.c customheader.h \
@@ -92,7 +93,6 @@ sylpheed_SOURCES = \
        base64.c base64.h \
        uuencode.c uuencode.h \
        md5.c md5.h \
-       rfc822.c rfc822.h \
        socket.c socket.h \
        ssl.c ssl.h \
        automaton.c automaton.h \
@@ -125,7 +125,6 @@ sylpheed_SOURCES = \
        matcher.c matcher.h \
        prefs_matcher.c prefs_matcher.h \
        prefs_scoring.c prefs_scoring.h \
-       prefs_actions.c prefs_actions.h \
        filtering.c filtering.h \
        prefs_filtering.c prefs_filtering.h \
        mbox_folder.c mbox_folder.h \
@@ -135,7 +134,9 @@ sylpheed_SOURCES = \
        matcher_parser_lex.l matcher_parser_lex.h \
        matcher_parser_parse.y matcher_parser.h matcher_parser_parse.h \
        string_match.h string_match.c \
-       selective_download.c selective_download.h
+       selective_download.c selective_download.h \
+       msgcache.h msgcache.c \
+       noticeview.h noticeview.c
 
 BUILT_SOURCES = \
        quote_fmt_lex.c \
@@ -208,11 +209,13 @@ EXTRA_DIST = \
        pixmaps/up_arrow.xpm \
        pixmaps/vcard.xpm \
        pixmaps/work_offline.xpm \
-       pixmaps/work_online.xpm
+       pixmaps/work_online.xpm \
+       pixmaps/notice_warn.xpm \
+       pixmaps/notice_error.xpm \
+       pixmaps/notice_note.xpm
 
 INCLUDES = \
        -DG_LOG_DOMAIN=\"Sylpheed\" \
-       -I$(top_srcdir)/libkcc \
        -I$(top_srcdir)/intl \
        $(GTK_CFLAGS) \
        $(GDK_IMLIB_CFLAGS) \
@@ -222,19 +225,19 @@ INCLUDES = \
        -I$(includedir)
 
 sylpheed_LDADD = \
-       $(top_builddir)/libkcc/libkcc.a \
        $(INTLLIBS) \
        $(GTK_LIBS) \
        $(GDK_IMLIB_LIBS) \
        $(GDK_PIXBUF_LIBS) \
        $(GPGME_LIBS) \
-        $(PSPELL_LIBS)
+        $(PSPELL_LIBS) \
+       $(LDAP_LIBS)
 
 CPPFLAGS = \
        -DLOCALEDIR=\""$(localedir)"\" \
        -DMANUALDIR=\""$(manualdir)"\" \
        -DFAQDIR=\""$(faqdir)"\" \
-       -DHOST_ALIAS=\""$(host_alias)"\" \
+       -DTARGET_ALIAS=\""$(target_alias)"\" \
        -DSYSCONFDIR=\""$(sysconfdir)"\"
 
 YFLAGS = -d