make return receipts work again
[claws.git] / src / Makefile.am
index 4663fecfd3d9d2c469a1683f6f41789b203197d5..b66fb1570f20e4388b18e7ed9c61b6d61cf11fc1 100644 (file)
@@ -23,15 +23,19 @@ sylpheed_SOURCES = \
        compose.c compose.h \
        gtkshruler.c gtkshruler.h \
        gtksctree.c gtksctree.h \
+       gtkstext.c gtkstext.h \
        menu.c menu.h \
+       stock_pixmap.c stock_pixmap.h \
        prefs.c prefs.h \
        prefs_common.c prefs_common.h \
        prefs_filter.c prefs_filter.h \
        prefs_account.c prefs_account.h \
+       prefs_folder_item.c prefs_folder_item.h \
        prefs_display_header.c prefs_display_header.h \
        prefs_customheader.c prefs_customheader.h \
        prefs_summary_column.c prefs_summary_column.h \
        prefs_template.c prefs_template.h \
+       prefs_actions.c prefs_actions.h \
        account.c account.h \
        displayheader.c displayheader.h \
        customheader.c customheader.h \
@@ -39,8 +43,11 @@ sylpheed_SOURCES = \
        addressbook.c addressbook.h \
        addr_compl.c addr_compl.h \
        addressitem.h \
+       adbookbase.h \
        addritem.c addritem.h \
        addrcache.c addrcache.h \
+       addrclip.c addrclip.h \
+       addrselect.c addrselect.h \
        addrbook.c addrbook.h \
        addrindex.c addrindex.h \
        mgutils.c mgutils.h \
@@ -49,6 +56,8 @@ sylpheed_SOURCES = \
        importldif.c importldif.h \
        mutt.c mutt.h \
        importmutt.c importmutt.h \
+       pine.c pine.h \
+       importpine.c importpine.h \
        jpilot.c jpilot.h \
        syldap.c syldap.h \
        editbook.c editbook.h \
@@ -59,13 +68,18 @@ sylpheed_SOURCES = \
        editldap.c editldap.h \
        editldap_basedn.c editldap_basedn.h \
        addressadd.c addressadd.h \
+       addrharvest.c addrharvest.h \
+       addrgather.c addrgather.h \
+       exporthtml.c exporthtml.h \
+       exphtmldlg.c exphtmldlg.h \
+       xmlprops.c xmlprops.h \
        filesel.c filesel.h \
        foldersel.c foldersel.h \
        statusbar.c statusbar.h \
-       headerwindow.c headerwindow.h \
        logwindow.c logwindow.h \
        sourcewindow.c sourcewindow.h \
        manage_window.c manage_window.h \
+       undo.c undo.h \
        alertpanel.c alertpanel.h \
        inputdialog.c inputdialog.h \
        progressdialog.c progressdialog.h \
@@ -79,13 +93,11 @@ sylpheed_SOURCES = \
        base64.c base64.h \
        uuencode.c uuencode.h \
        md5.c md5.h \
-       rfc822.c rfc822.h \
        socket.c socket.h \
        ssl.c ssl.h \
        automaton.c automaton.h \
        session.c session.h \
        smtp.c smtp.h \
-       esmtp.c esmtp.h \
        pop.c pop.h \
        mh.c mh.h \
        mbox.c mbox.h \
@@ -99,6 +111,7 @@ sylpheed_SOURCES = \
        imap.c imap.h \
        xml.c xml.h \
        html.c html.h \
+       enriched.c enriched.h \
        procmime.c procmime.h \
        rfc2015.c rfc2015.h \
        passphrase.c passphrase.h \
@@ -108,9 +121,7 @@ sylpheed_SOURCES = \
        simple-gettext.c \
        manual.c manual.h \
        stringtable.c stringtable.h \
-       gtkstext.c gtkstext.h \
        scoring.c scoring.h \
-       prefs_folder_item.c prefs_folder_item.h \
        matcher.c matcher.h \
        prefs_matcher.c prefs_matcher.h \
        prefs_scoring.c prefs_scoring.h \
@@ -118,10 +129,14 @@ sylpheed_SOURCES = \
        prefs_filtering.c prefs_filtering.h \
        mbox_folder.c mbox_folder.h \
        quote_fmt_lex.l quote_fmt_lex.h \
-       quote_fmt_parse.y quote_fmt.h \
+       quote_fmt_parse.y quote_fmt.c quote_fmt.h \
        gtkspell.c gtkspell.h gtkxtext.h \
        matcher_parser_lex.l matcher_parser_lex.h \
-       matcher_parser_parse.y matcher_parser.h
+       matcher_parser_parse.y matcher_parser.h matcher_parser_parse.h \
+       string_match.h string_match.c \
+       selective_download.c selective_download.h \
+       msgcache.h msgcache.c \
+       noticeview.h noticeview.c
 
 BUILT_SOURCES = \
        quote_fmt_lex.c \
@@ -134,81 +149,95 @@ BUILT_SOURCES = \
 EXTRA_DIST = \
        quote_fmt_parse.h \
        version.h.in \
+       pixmaps/address_book.xpm \
+       pixmaps/address.xpm \
+       pixmaps/book.xpm \
+       pixmaps/category.xpm \
+       pixmaps/checkbox_off.xpm \
+       pixmaps/checkbox_on.xpm \
        pixmaps/clip.xpm \
+       pixmaps/clipkey.xpm \
+       pixmaps/close.xpm \
+       pixmaps/complete.xpm \
+       pixmaps/continue.xpm \
        pixmaps/deleted.xpm \
-       pixmaps/dir-close.xpm \
-       pixmaps/dir-open.xpm \
+       pixmaps/dir_close.xpm \
+       pixmaps/dir_open.xpm \
+       pixmaps/dir_open_hrm.xpm \
+       pixmaps/down_arrow.xpm \
+       pixmaps/error.xpm \
+       pixmaps/exec.xpm \
        pixmaps/folder.xpm \
        pixmaps/forwarded.xpm \
        pixmaps/group.xpm \
+       pixmaps/ignorethread.xpm \
        pixmaps/inbox.xpm \
+       pixmaps/inbox_hrm.xpm \
+       pixmaps/interface.xpm \
+       pixmaps/jpilot.xpm \
+       pixmaps/key.xpm \
+       pixmaps/ldap.xpm \
+       pixmaps/linewrap.xpm \
+       pixmaps/locked.xpm \
+       pixmaps/mail.xpm \
+       pixmaps/mail_attach.xpm \
+       pixmaps/mail_compose.xpm \
+       pixmaps/mail_forward.xpm \
+       pixmaps/mail_receive.xpm \
+       pixmaps/mail_receive_all.xpm \
+       pixmaps/mail_reply.xpm \
+       pixmaps/mail_reply_to_all.xpm \
+       pixmaps/mail_reply_to_author.xpm \
+       pixmaps/mail_send.xpm \
+       pixmaps/mail_send_queue.xpm \
        pixmaps/mark.xpm \
-       pixmaps/checkbox_on.xpm \
-       pixmaps/checkbox_off.xpm \
        pixmaps/new.xpm \
+       pixmaps/news_compose.xpm \
        pixmaps/outbox.xpm \
+       pixmaps/outbox_hrm.xpm \
+       pixmaps/paste.xpm \
+       pixmaps/preferences.xpm \
+       pixmaps/properties.xpm \
        pixmaps/regular.xpm \
        pixmaps/replied.xpm \
+       pixmaps/search.xpm \
+       pixmaps/sylpheed.xpm \
+       pixmaps/sylpheed_logo.xpm \
        pixmaps/trash.xpm \
+       pixmaps/trash_hrm.xpm \
        pixmaps/unread.xpm \
-       pixmaps/linewrap.xpm \
-       pixmaps/continue.xpm \
-       pixmaps/complete.xpm \
-       pixmaps/error.xpm \
-       pixmaps/stock_mail.xpm \
-       pixmaps/stock_mail_attach.xpm \
-       pixmaps/stock_mail_receive.xpm \
-       pixmaps/stock_mail_receive_all.xpm \
-       pixmaps/stock_mail_send.xpm \
-       pixmaps/stock_mail_send_queue.xpm \
-       pixmaps/stock_mail_compose.xpm \
-       pixmaps/stock_news_compose.xpm \
-       pixmaps/stock_mail_reply.xpm \
-       pixmaps/stock_mail_reply_to_all.xpm \
-       pixmaps/stock_mail_reply_to_author.xpm \
-       pixmaps/stock_mail_forward.xpm \
-       pixmaps/stock_preferences.xpm \
-       pixmaps/stock_properties.xpm \
-       pixmaps/stock_search.xpm \
-       pixmaps/stock_close.xpm \
-       pixmaps/stock_exec.xpm \
-       pixmaps/stock_trash.xpm \
-       pixmaps/stock_up_arrow.xpm \
-       pixmaps/stock_down_arrow.xpm \
-       pixmaps/stock_paste.xpm \
-       pixmaps/tb_address_book.xpm \
-       pixmaps/sylpheed-logo.xpm \
-       pixmaps/address.xpm \
-       pixmaps/book.xpm \
-       pixmaps/category.xpm \
-       pixmaps/interface.xpm \
-       pixmaps/jpilot.xpm \
-       pixmaps/ldap.xpm \
-       pixmaps/vcard.xpm
+       pixmaps/up_arrow.xpm \
+       pixmaps/vcard.xpm \
+       pixmaps/work_offline.xpm \
+       pixmaps/work_online.xpm \
+       pixmaps/notice_warn.xpm \
+       pixmaps/notice_error.xpm \
+       pixmaps/notice_note.xpm
 
 INCLUDES = \
        -DG_LOG_DOMAIN=\"Sylpheed\" \
-       -I$(top_srcdir)/libkcc \
        -I$(top_srcdir)/intl \
        $(GTK_CFLAGS) \
        $(GDK_IMLIB_CFLAGS) \
        $(GDK_PIXBUF_CFLAGS) \
+       $(GPGME_CFLAGS) \
         $(PSPELL_CFLAGS)    \
        -I$(includedir)
 
 sylpheed_LDADD = \
-       $(top_builddir)/libkcc/libkcc.a \
        $(INTLLIBS) \
        $(GTK_LIBS) \
        $(GDK_IMLIB_LIBS) \
        $(GDK_PIXBUF_LIBS) \
        $(GPGME_LIBS) \
-        $(PSPELL_LIBS)
+        $(PSPELL_LIBS) \
+       $(LDAP_LIBS)
 
 CPPFLAGS = \
        -DLOCALEDIR=\""$(localedir)"\" \
        -DMANUALDIR=\""$(manualdir)"\" \
-       -DHOST_ALIAS=\""$(host_alias)"\" \
+       -DFAQDIR=\""$(faqdir)"\" \
+       -DTARGET_ALIAS=\""$(target_alias)"\" \
        -DSYSCONFDIR=\""$(sysconfdir)"\"
 
 YFLAGS = -d