2005-10-19 [colin] 1.9.15cvs75
[claws.git] / src / Makefile.am
index aa54d64448125d1623561cd8f376fcb92e55d471..aa606339100e56eb8a0fe3750cc16b9530e3feaa 100644 (file)
@@ -1,8 +1,8 @@
-SUBDIRS = common gtk plugins
+SUBDIRS = common gtk plugins etpan
 
-bin_PROGRAMS = sylpheed
+bin_PROGRAMS = sylpheed-claws
 
-sylpheed_SOURCES = \
+sylpheed_claws_SOURCES = \
        account.c \
        action.c \
        addrbook.c \
@@ -43,6 +43,7 @@ sylpheed_SOURCES = \
        foldersel.c \
        folderutils.c \
        folderview.c \
+       gedit-print.c \
        grouplistdialog.c \
        headerview.c \
        html.c \
@@ -96,11 +97,16 @@ sylpheed_SOURCES = \
        prefs_gtk.c \
        prefs_image_viewer.c \
        prefs_matcher.c \
+       prefs_message.c \
        prefs_msg_colors.c \
+       prefs_other.c \
        prefs_quote.c \
+       prefs_receive.c \
+       prefs_send.c \
        prefs_spelling.c \
        prefs_summaries.c \
        prefs_summary_column.c \
+       prefs_folder_column.c \
        prefs_template.c \
        prefs_themes.c \
        prefs_toolbar.c \
@@ -130,8 +136,8 @@ sylpheed_SOURCES = \
        vcard.c \
        wizard.c
 
-sylpheedincludedir = $(pkgincludedir)
-sylpheedinclude_HEADERS = \
+sylpheed_clawsincludedir = $(pkgincludedir)
+sylpheed_clawsinclude_HEADERS = \
        account.h \
        action.h \
        adbookbase.h \
@@ -175,6 +181,7 @@ sylpheedinclude_HEADERS = \
        foldersel.h \
        folderutils.h \
        folderview.h \
+       gedit-print.h \
        grouplistdialog.h \
        headerview.h \
        html.h \
@@ -229,11 +236,16 @@ sylpheedinclude_HEADERS = \
        prefs_gtk.h \
        prefs_image_viewer.h \
        prefs_matcher.h \
+       prefs_message.h \
        prefs_msg_colors.h \
+       prefs_other.h \
        prefs_quote.h \
+       prefs_receive.h \
+       prefs_send.h \
        prefs_spelling.h \
        prefs_summaries.h \
        prefs_summary_column.h \
+       prefs_folder_column.h \
        prefs_template.h \
        prefs_themes.h \
        prefs_toolbar.h \
@@ -355,19 +367,35 @@ EXTRA_DIST = \
        pixmaps/sylpheed.xpm \
        pixmaps/trash_hrm.xpm \
        pixmaps/trash.xpm \
+       pixmaps/trash_btn.xpm \
        pixmaps/unread.xpm \
        pixmaps/read.xpm \
        pixmaps/up_arrow.xpm \
-       pixmaps/vcard.xpm
+       pixmaps/vcard.xpm \
+       pixmaps/dir_close_mark.xpm \
+       pixmaps/dir_open_hrm_mark.xpm \
+       pixmaps/dir_open_mark.xpm \
+       pixmaps/drafts_close_mark.xpm \
+       pixmaps/drafts_open_mark.xpm \
+       pixmaps/inbox_hrm_mark.xpm \
+       pixmaps/inbox_mark.xpm \
+       pixmaps/outbox_hrm_mark.xpm \
+       pixmaps/outbox_mark.xpm \
+       pixmaps/trash_hrm_mark.xpm \
+       pixmaps/trash_mark.xpm \
+       pixmaps/empty.xpm
+
 
 INCLUDES = \
        -Icommon \
-       -Igtk
+       -Igtk \
+       -Ietpan
 
-sylpheed_LDFLAGS = \
+sylpheed_claws_LDFLAGS = \
        -export-dynamic
 
-sylpheed_LDADD = \
+sylpheed_claws_LDADD = \
+       etpan/libsylpheedetpan.la \
        gtk/libsylpheedgtk.la \
        $(ASPELL_LIBS) \
        $(INTLLIBS) \
@@ -378,11 +406,13 @@ sylpheed_LDADD = \
        $(COMPFACE_LIBS) \
        $(JPILOT_LIBS) \
        $(PTHREAD_LIBS) \
+       $(GNOMEPRINT_LIBS) \
        $(LIBICONV) \
-       $(STARTUP_NOTIFICATION_LIBS)
+       $(STARTUP_NOTIFICATION_LIBS) \
+       $(LIBETPAN_LIBS)
 
 AM_CPPFLAGS = \
-       -DG_LOG_DOMAIN=\"Sylpheed\" \
+       -DG_LOG_DOMAIN=\"Sylpheed-Claws\" \
        -DLOCALEDIR=\""$(localedir)"\" \
        -DMANUALDIR=\""$(manualdir)"\" \
        -DFAQDIR=\""$(faqdir)"\" \
@@ -392,6 +422,14 @@ AM_CPPFLAGS = \
        $(GTK_CFLAGS) \
        $(GPGME_CFLAGS) \
        $(OPENSSL_CFLAGS) \
-       $(STARTUP_NOTIFICATION_CFLAGS)
+       $(GNOMEPRINT_CFLAGS) \
+       $(LIBETPAN_CPPFLAGS) \
+       $(STARTUP_NOTIFICATION_CFLAGS) \
+       -Wno-unused-function
+        
+#no-unused-function is there because of bison stuff
+#no-deprecated-declarations because of gpgme_data_rewind, which we have
+#to call inside gpgme due to our lack of LARGEFILE support
 
+       
 AM_YFLAGS = -d